Version 2.2.2.0 - Still get Exception on Table.Height if set a Portion Font Height


#1

Alexey,

Am I doing something wrong? I am still getting an exception with
the latest version of the library any time that I set a Font Height for
a portion in a table… I doesn’t take much code to cause the
problem:



Presentation pres = new Presentation(@“C:\empty.ppt”);



Slide slide = pres.Slides[0];

Table table = slide.Shapes.AddTable(1576, 1576, 4576, 3576, 2, 4);



Cell cell = table.GetCell(0,0);



cell.TextFrame.Paragraphs[0].Portions[0].FontHeight = 9;

cell.TextFrame.Paragraphs[0].Portions[0].Text = “Test text”;



// Code throws Exception Here

Console.Out.WriteLine("Table Height: " + table.Height);



If I comment out the line setting FontHeight = 9 then it works.
Unfortunately our production system needs to have font sizes set for
our production powerpoint documents.



The powerpoint template that I’m starting with is a single empty slide:



Thanks

Chris


#2

Dear Chris,



Please check 2.2.3.0 hot fix. It should solve your problem.

We didn’t add support for newly created tables in 2.2.2.


#3

Alexey…

I just tried to download 2.2.3.0 but the download page is broken?



Server Error in ‘/Downloads’ Application.

--------------------------------------------------------------------------------



Could not find a part of the path
“c:\hosting\webhost4life\member\aspose\www\Downloads\Data\Aspose.PowerPoint\2.2.3.0\Aspose.PowerPoint.zip”.


#4

Looks like there is a problem with our new downloads.

Please check attached zip with 2.2.3 hot fix.