What should i do when i am given a new Aspose.Cells.dll version

I created a project with an old version of Aspose.Cells (7.3). It compiled and ran perfectly in my machine. Then I tried to install and run on a test server, but it wouldn’t - said it couldn’t find Aspose.Cells.dll in System32 folder (although it was there). So I assumed it could be because of the old version.

My supervisor got the latest version (8.4.2) and emailed the dll and lic to me. I tried putting the dll and lic in the project folder, in System32 folder, but no matter where - the project would no longer compile. Should I do anything with this dll before it will work on my machine? What am I missing here?

Thanks
Sreejith

Hi,

Thanks for your posting and using Aspose.Cells.

Please remove the reference of old dll and add the reference of new dll inside your project and it should work fine.

Also, I have attached a sample test project, please download it and run it at your end and see how it behaves. It should print the current version of Aspose.Cells dll which is 8.4.2.0 and create a workbook object with worksheet which has “Welcome to Aspose!” string in cell A1.

Please run it at your end and let us know your feedback.

Also let us know if your .net framework is Client Profile or if it is a Regular framework. For Client Profile framework, there is a separate Aspose.Cells dll.


I believe that was where my issue was. It was showing Client profile framework initially, and after I changed to regular framework, it worked. Thanks for the reply.

Hi,

Thanks for your feedback and using Aspose.Cells.

It is good to know that your issue is sorted out now. Let us know if you encounter any other issue, we will be glad to look into it and help you further.