We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

When converting HTML to docx- "shy entities" are always rendered as hyphens

With HTML you can use the ­ entity for the purpose of breaking words across lines by inserting visible hyphens, BUT only when needed.

When transforming a HTML file containing some of these ­ entities to a docx file using Aspose, the ­ entities are always rendered as hyphens, even though there’s enough space to render the word without hyphens.

Is there an option/setting we could use to prevent this from happening?

(I attached a small Java project to demonstrate the problem.)

Hi Bart,

Thanks for your inquiry. We have tested the scenario and have managed to reproduce the same issue at our side. For the sake of correction, we have logged this problem in our issue tracking system as WORDSNET-13990. You will be notified via this forum thread once this issue is resolved.

We apologize for your inconvenience.

Thank you for looking into this!

The issues you have found earlier (filed as WORDSNET-13990) have been fixed in this Aspose.Words for .NET 16.12.0 update and this Aspose.Words for Java 16.12.0 update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.