Free Support Forum - aspose.com

Will Aspose.words work on Java 1.7?

Hello,



I see that Aspose.Words for Java only comes with libraries for Java 1.4 - 1.6, and this is all that is advertised as supported (and covered in the FAQ).



However, I was wondering if it the 1.6 libraries will work with Java 1.7? (And if not, if there are plans to add support for 1.7 in the near future?)



Apologies if this has been asked a lot, but the forum search feature didn’t like the “1.7” and seemed to ignore it.



Thanks!

Hi Keith,


Thanks for your inquiry. Currently, we don’t ship a separate library specifically written for Java 7; however, Aspose.Words supports J2SE 7.0 (1.7); so, please use 1.6 libraries . For more information, please read the following article:
http://www.aspose.com/docs/display/wordsjava/System+Requirements

Best Regards,

Great, thanks Awais, that’s fantastic news!

All the best,

Keith

Hi Keith,


Thanks for your interest in Aspose.Words. Please let us know any time you have any further queries. We are always glad to help you.

Best Regards,