We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Windows 7 Professional 64-bit

Hello,

We are getting "is not a valid Win32 application. (Exception from HRESULT: 0x800700C1)" trying to instanciate Aspose.Cells.Workbook on Windows 7 64-bit, we are uisng Aspose.Cells version 4.8.0.0 from 'C:\Program Files\Aspose\Aspose.Cells for .NET\Bin\Net1.0'.

Running the same code on a 32-bit environment works fine.

We tried with the Aspose.Cells.dll from 'C:\Program Files\Aspose\Aspose.Cells for .NET\Bin\Net2.0' on the Windows 7 64-bit machine and it worked fine.

Should we deploy Aspose.Cells.dll depending on the system type (32-bit or 64-bit) or is it safe to deploy Aspose.Cells.dll from the folder Net2.0 regardless of the system type?

Thanks,

Juno

Hi,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for considering Aspose.

You may deploy Aspose.Cells.dll from the folder Net2.0 for both 32 bit & 64 bit machines as it will work fine with both of them.

Thank you & Best Regards,