Word crashing on mac when I print a document generated by aspose.word


#1

I wonder if anyone else has hit this problem.

After creating a document with aspose.word and downloading it on a mac (Word 98) when I click print the computer freezes completely. You cannot even force escape.

I need to know if this an aspose.word problem (probably not) or a Mac word issue. I have tried to download the document on a windows machine and have met with no problems.

Hence, my suspicion that it is a Mac Word document issue.

Can anyone help.

Cheers,

Neil.


#2

Hi Neil,

It is likely to be caused by Aspose.Word. There are many subtle and confusingly documented features in Word file format so it is likely that Aspose.Word produces documents that are slightly different from the original format. Windows version maybe processing them okay while any other reader like Word for Mac could stumble.

What we can do:
1. Download and try using latest Aspose.Word 1.1.4 because it had some file format related improvements.
2. If still crashing, send the original merge document to word@aspose.com.


#3

Just wanted to know if you guys recieved my word file yesterday.

I tried the 1.1.4 version and the Mac word still crashes when I try and print the document.

Neil.


#4

Please send me the document, I will run diagnostics to see what structures we build differently from the original.


#5

Thanks Neil, I’ve got the file and will do some testing. I expect to have some results by Monday or so.


#6

Great Thanks v. much for all that you do.

Cheers,

Neil.


#7

Hi Neil,

In fact you can help to speed the resolution up. Let me know if you can do this for me:

1. Write three line code that opens a word document and saves it using Aspose.Word. Don’t even need to invoke MailMerge.

2. Create an Empty Word document and run it through that code. Try opening in Macintosh Word. If it crashes, report to me, if does not crash then continue.

3. Add some text to your Word document, maybe just a couple of paragraphs. Do same as in p.2.

4. Add some formatting to the text, repeat test as above.

5. Add a continious section break to the document, do same as above.

6. Add a table to the document, repeat test as above.

7. Add a mail merge field to the document, repeat test as above.

8. Add an imae to the document, repeat test as above.

By this series of quick tests we will establish what document feature is written incorrectly.


#8

Also your document seems to have some revision marks. Technically speaking Aspose.Word does not support revision marks yet.

Revision marks could well be causing the problem you have.

So before you attempt any of the test above, please accept all revision marks so there are none left and run your code again and test with Word for Macintosh.


#9

Small question…what is a revision mark? If there are these types of marks in my document I did not knowingly put the in there.

Cheers,

Neil.


#10

Revisions or track changes is a featrue in Word. When it is turned on Word remembers what changes you made to the document and highlights them so the reviewer who reviews the document later can accept the changes or reject them.

You control this feature from Tools/Track Changes feature in Word and also View/Toolbars/Reviewing.

Your document seems to have been edited since Track Changes feature was turned on. You have two changes tracked - I think they are paragraph marks at the ends of the two last fields in the document.

You must accepts those changes and switch Track Changes off for the document. Right click on the changes (you should see them in different color) and select Accept Changes or there must be a menu in Tools to accept all changes.

Once that is done switch track changes off.

Now run your document through Aspose.Word and come back if it still crashes.