Free Support Forum - aspose.com

Word fields appear boxed when document saved as PDF

When the attached DOCX form is saved as a PDF, the fields in the form appear boxed in the resulting Acrobat file. I didn't find a way to turn this off in Acrobat, so I assume that this is something Aspose is doing to create the boxes. Is there a way to remove the boxes?

Boxed.txt is the C# code I'm using to save this document.

Boxed.jpg illustrates the problem.

Jim McFadden / Unum / Chattanooga, TN, USA

One other point: In the PDF, the boxes obscure the underline that should be visible under the text and can be clearly seen in the DOCX.

Jim McFadden / Unum / Chattanooga, TN, USA

Hello<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your request. Please just try setting IsPreserveFormFields to false.

Please let me know in case of any issues. I will be glad to help you.

Best regards,

IsPreserveFormFields is set to true because checkboxes on forms do not display correctly.

http://www.aspose.com/community/forums/thread/232837/issues-while-evaluating-aspose.words.aspx

While there are no checkboxes on this particular form, I have many other forms that do contain checkboxes and many will also contain Word fields. Unless I can make checkboxes appear correctly using some other method, this solution is not going to work.

Jim McFadden / Unum / Chattanooga, TN, USA

Hello

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for additional information. As I understand from the thread you have provided above, the problem with CheckBoxes has been fixed after installation Wingdings2 font. Am I right? I cannot reproduce the problem on my side using the latest version of Aspose.Words 9.1.0.

Best regards,

In the thread mentioned above, there were two steps to the checkbox solution. Prior to setting the PreserveFormFields option to true, checkboxes appeared as vertical lines. Setting the option fixed that problem, and everything looked fine on my development workstation. However, I then found that the checkboxes overlapped text when the code was run on my server. Installing the Wingdings 2 font solved that problem.

In other words, setting the PreserveFormFields option is still a requirement for me unless you're saying the issue with the checkboxes-as-vertical-lines issue has been solved and PreserveFormFields is no longer necessary. I notice that you reference version 9.1.0 of the product. My Aspose.Words DLL displays version 9.0.0 built April 7, 2010. If I've got an older version and should upgrade, I'd be happy to do so. I do not see any place on your web site that lists current versions of the products. Is there a way I should be able to tell when you've released an update?

Thanks.

Jim McFadden / Unum / Chattanooga, TN USA

Hi,

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your inquiry. You can check for the latest version of Aspose.Words on the download page of this product. Also, you can enable e-mail subscription on Aspose.Words download page and you will receive notification each time when new release comes out.

http://www.aspose.com/community/files/51/.net-components/aspose.words-for-.net/category1188.aspx

Best regards.

Hi Jim,

Yes you should try using the latest version of Aspose.Words for .NET 9.1. I quickly tested using both your documents from this thread and your original thread regarding the checkboxes that you discussed. Using the Save method and without enabling preserve form fields the checkboxes appeared correctly, I could not reproduce the checkboxes being rendered as vertical lines.

Could you please briefly explain exactly what you would like the PDF to appear as? This may help us to better understand your situation. Do you want the PDF to have editable fields or are you only using that as a work around for the issues described on your other threads? In other words, do the users enter the data into the fields in the .docx file or the PDF file?

It appears at the moment all form fields are given a box around them, if you don’t need the form fields editable in the PDF file then you could try just using the new version and disable preserving form fields.

Thanks,

While it's always possible that our business users could require editable form fields in the future, right now we don't need editable form fields in the PDFs. We were only using the PreserveFormFields option in order to make the check boxes appear correctly.

The business scenario is that they give IT a Word document with instructions to convert the document to a TIF (in which case editable form fields don't matter) or to convert the document to a PDF. In the latter case, I don't believe form fields matter, either, because the PDF is emailed to a customer for them to print out. No one has asked for PDFs to be editable, but you raise a good point and I will need to follow up with my business partner to find out.

Either way, if the latest version of Aspose fixes the checkbox problem, that should also fix my problem.

FWIW: I realize I've posted a number of issues to the forum lately, and I appreicate Adam, Alexey and your help in sorting through the problems.

Thanks for your time.

Jim McFadden / Unum / Chattanooga, TN USA

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for additional information. You should just install Wingdings 2 font to render checkboxes properly. You do not need change any settings. Wingdings 2 font is required because Wingdings characters are used to render checkboxes in PDF.

Best regards.