We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Word { PRINT } field codes are not working

Hi,


I’m currently experiencing difficulties while printing a word document, having a standard PRINT field code, to a postscript document using the Aspose.Words API.

The document itself simply contains the field code

{ PRINT “%%Dummy42” * MERGEFORMAT }.

Upon printing the document to a postscript file, I don’t get the PRINT field code embedded into the postscript file, as I do when printing directly from Word. I’ve tried using various postscript drivers to verify the problem wasn’t related to a driver issue.

If possible, how can I solve this problem such that I can get the PRINT field code embedded in the postscript file?

Kind regards,
Engel

Hi
Søren,


Thanks for your inquiry. I would suggest you please upgrade to the latest version of Aspose.Words i.e. 11.2.0 and let us know how it goes on your side. You can download it from the following link:
http://www.aspose.com/community/files/51/.net-components/aspose.words-for-.net/default.aspx

I hope, this will help.

Best Regards,

Hi Awais,


I’ve now updated the Aspose.Words assemblies in my project to the latest and greatest version. However, I still don’t get the {PRINT} instruction embedded into the postscript file.

I was looking at the following link, and wondered if it is even possible for me to make use of this Word functionality?:
http://www.aspose.com/docs/display/wordsnet/Field+Features+Supported+on+Print+Export

If not, can you propose a workaround?

Kind regards,
~ Engel

To hijack this thread, we have more or less the same issue. We used to generate PRN files from Word with print field codes. When we try this using the Aspose components the codes are ignored.

So an update supporting this or workaround would be nice.

Thanks,

Wim

Hi,


Thanks for the additional information and sorry for the delayed response. I have logged a new feature request in our bug tracking system as WORDSNET-6258. Your thread has also been linked to this feature and you will be notified as soon as it is supported. Sorry for the inconvenience.

Best Regards,

Hi,

Is there anywhere I can check the progress or ETA on this?

Thank you,

Wim

Hi Wim,


Thanks for your inquiry. We will keep you informed regarding the status of this issue and let you know via this forum thread once this feature is supported.

Best Regards,

Hi,

Is there any progress in the fix for the fieldcode 'PRINT'. All our documents are using the PRINT code, for duplex printing, choosing which printer tray to use, the number of copies.

I tried other methods to accomplish this, but with no result. The problem is that we use multiple printcodes on multiple pages, so I can't set default printing options in the printersettings.

ex. I have a document of 7 pages:

  • The first page is Simplex printed on tray B
  • Page 2 and 3 are Duplex printed on tray A
  • the other pages are Simplex printed on tray A
  • The document has to be printed 3 times

Thanks,

Bart

Hi Bart,


Thanks for your inquiry. I have verified the status of WORDSNET-6258 from our issue tracking system and regret to share with you that the implementation this new feature ‘Support PRINT field during rendering’ has been postponed till a later date. I am afraid, we cannot push it into production right now because there are many other important issues we have to work on. We apologise for any inconvenience.

Best Regards,

Hi there,


Just a quick suggestion, you might be able to achieve the same by using the PageSetup.FirstPageTray and PageSetup.OtherPagesTray property.

We will inform you as soon as there is any developments regarding your reported issue.

Thanks,