We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Word reference is not shown correctly when saving as PDF

Hi

We have experienced a problem when saving Word documents as PDF.

I have verified it both with the version we use in production (14.12) and newest download (15.6).

In 15.6 it seems to be a bit better, as the referenced reference is now a zero (0) instead of nothing.

I have attached a working sample in C# (WordToPdfMachine.zip). To get it working the parameter LICENSEFILE needs to hold the contents of a valid aspose Words license file.

To run it supply it with a valid path to a Word document. A test document is attached as well (mstest.docx).

Execute as “WordToPdfMachine.exe C:\temp\mstest.docx”.
It will then create a new Pdf file with same file name, just with PDF as extension.

Attached is also a screenshot of how Word vs. PDF looks in my end. (mstestscreenshot.png)

I have tried to figure out what goes wrong - but can’t find any obvious flaws.

Hope you can assist figuring out what is wrong and conclude whether this is a bug in Aspose or in our way of using it.

Best regards
/Anders

Hi Anders,

If you open the document in MS Word and save as PDF, the referenced reference will be converted to 0 in output PDF as well as input DOCX so this is expected behavior in case of Aspose.Words.

Can you please check at your end and let us know if you see the same output using MS Word?

Best Regards,

Hi


That it’s fair enough about the zero. Hadn’t even tried that myself.

But the text 4.1 Text marked with red on the lower circle is in the output if Word saves as PDF, but not when Aspose saves as PDF.

But there are clearly some weirdness in how our customer has created the document that makes it somewhat invalid sinve Word can’t save it as PDF correctly as well.



Hi Anders,

Thanks for the clarification. This issue has been logged into our issue tracking system as WORDSNET-12220.

We will keep you updated on this issue in this thread.

Best Regards,

The issues you have found earlier (filed as WORDSNET-12220) have been fixed in this .NET update and this Java update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.