Free Support Forum - aspose.com

WordML to PDF generates different output for same template in different applications

I have been playing around with aspose.words to convert worldml files to pdf.
I have a document who's output does not generate correctly in the application im integrating it with.

To investigate further i wrote a simple standalone windows forms app, to convert the same template. But I the stand alone product generates the document fine and correctly. So im rather confused, ive been trying to find the difference between the two applications but am stumped as to what the problem could be.

The document in questions output varies with text in the header. In one application the document outputs in black text, and the other the text appears to be white (on white background) i cannot see the text, but its there as i can cut and paste it.

The code in both is the same:

Aspose.Words.Document conversiondoc = new Aspose.Words.Document(tempFileName);
conversiondoc.Save(outputFileName, SaveFormat.Pdf);

Can I get some advice on how to investigate this problem further , and what information details I can provide ?Has this issue come up before?

I cant upload the non working application as its a rather vast code base, and i cannot get the small standalone version to re-produce the problem.

Some of the things i thought of where where:

1. The version of the .net framework are the same - it turned out they differed the working one was .net 3.5 and the failing application was .net 2.0 so I made both .net 2.0 (made no difference)
2. The save and compatibility options are the same (i looked at it manually and they appear to be the same)
3. The same physical file is being picked up and generated (i debugged each app and made sure they picked up the same source file and generated it into pdf)
4. Use of other aspose libraries - it turned out we are also using aspose.cells an older version in the application that has the incorrect pdf output. I added the creation of an empty workbook to the working application, it made no difference.
5. The same version of aspose.words is being used in both apps.

Any help would be appreciated. I have attached an example.

Thanks, Luch.

Hello

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your request. I cannot reproduce the problem on my side. Do you perform some processing of the document before converting to PDF or just convert it? Could you please create a simple application, which will allow me to reproduce the problem on my side?

Best regards,

Yes we do perform processing of the document before conversion. But i reduced the logic down to taking the template from disk and only converting it to PDF.

That is my problem I cannot re-produce the problem in a simple App, it only happens in our complex application? Any advice on how i could create the simple app to re-produce it outside our main app would be helpful.

Thanks, Luch.

Ok I have managed to write a simple app that can reproduce the problem.
As attached.

Its a visual studio 2005 project on .NET 2.0, but i do get the same result in VS2008 .net 2.0

If you run it in the IDE and Hit Play and run it interactively the output generates fine.

If you close the IDE and run the compiled EXE manually from the bin\debug folder it generates the incorrect output as described.

Thanks, Luch.

Hello

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for additional information. I cannot reproduce the problem on my side. I tried using your application, but still cannot reproduce the problem.

Best regards,

Before I investigate further can I confirm you tried running it as a standalone without visual studio, and also running it with visual studio and you get the same output result ???

If this is the case then maybe its something environmental related, and ill look into it further.

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your request. I managed to reproduce the problem by running application you attached without IDE. However, once I rebuild the application (Aspose.Words 8.2.0 is used) the problem disappears. After rebuilding the application with the latest version of Aspose.Words your application works fine even without IDE. So please try using the latest version of Aspose.Words. You can download it from here:

http://www.aspose.com/community/files/51/.net-components/aspose.words-for-.net/category1188.aspx

Best regards.

The new version of the DLL works and fixes this problem.

Thanks.