We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Wordtopdf with radio button fails to convert

we are having issues on docker debian that when the docx has a radio button the conversion fails to happen.

@nightcoder,

Have you also tried the latest (21.9) version of Aspose.Words for .NET on your end? In case the problem still remains, then please ZIP and upload your input Word document you are getting this problem with here for testing. We will then investigate the issue on our end and provide you more information.

ActiveXControls_Testing.pdf (25.5 KB)
This file doesn’t convert. Using version 21.9
Our users use windows mostly. That said, we are using dotnet core to run functions to modify openxml documents and word documents in general. These active x controls may not run on linux, but word should load them and they should convert in kind.

@nightcoder,

You have only attached the Aspose.Words generated PDF file. Can you please set the PdfSaveOptions.PreserveFormFields Property to true and see if it produces correct results on your end? Please also compress the following resources into ZIP format and attach the .zip file here for testing:

  • A simplified source Word document you are getting this problem with
  • Your expected PDF file showing the desired output. You can create this output PDF file manually by using MS Word.

As soon as you get these pieces of information ready, we will then start further investigation into your particular scenario and provide you more information.

ActiveXControls_Testing.docx (30.2 KB)

Yes I attached the wrong file. can you run it on linux?

This is all I can give you for code and I sent the docx file. I can’t give anything more.
The code for linux looks like this:

byte[] byteArray = Encoding.ASCII.GetBytes(lic);
MemoryStream stream = new MemoryStream(byteArray);
Aspose.Words.License license = new Aspose.Words.License();
license.SetLicense(stream);
var w = new Aspose.Words.Document(memoryStream);
                       
PdfSaveOptions saveOptions = new PdfSaveOptions();
saveOptions.PreserveFormFields = true;
saveOptions.SaveFormat = Aspose.Words.SaveFormat.Pdf;
w.Save(memoutput, saveOptions);

Aspose Support - Here is our issue, we purchased license for aspose word and project that used it is set up in .net core. This endpoint is deployed in docker (linux debian) and when a word doc with activeX controls is converted to PDF - we get 502 bad getaway. If no ActiveX contros, all is good.
Same code deployed on windows servers is working as expected, we are under a deadline and need support. Have tried PDF options.
So it is deployment to linux debian docker containers is not working. Please suggest.

@nightcoder,

I tested the scenario on Windows 10 and a Ubuntu machine but the code does not throw any exceptions during converting ActiveXControls_Testing.docx to PDF on my end. Please check the following PDF files:

However, radio button, up down controls, shaded picture box and a few command buttons are not visible inside the PDF generated on my Ubuntu machine. Are these the problems you are asking about?

Please see my reply above - so it is Linux ubuntu docker container.

Yes, for us PDF can’t be opened and is corrupted.

Docker Image is -> mcr.microsoft.com/dotnet/aspnet:5.0

@usharma,

We will prepare the required platform to simulate the environment as that of yours. As soon as everything is setup, we will test your scenario and post the results here for your kind reference.

Thanks @awais.hafeez. Our cloud team mentioned that they can point to ubuntu image, which ubuntu tag are you using out of this. We are using .net core 5 as well.
https://mcrflowprodcentralus.data.mcr.microsoft.com/mcrprod/dotnet/sdk?P1=1632763987&P2=1&P3=1&P4=Hamjh6eIs6gefnPL%2FOheN6HJXdRzGMy0Po68sguVtFU%3D&se=2021-09-27T17%3A33%3A07Z&sig=HEGVyuhhbbmZE0I86bc49PoYB%2FU3wnmNytfw9MVr%2BIo%3D&sp=r&sr=b&sv=2015-02-21

@usharma,

On my end, the link you provided in last post displays the following error message:

ERROR 403: Time-Limited URL validation failed

However, the lsb_release -a command gives the following results on my test VM:

No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 21.04
Release:	21.04
Codename:	hirsute

And dotnet --version displays:

5.0.401