We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Worksheet Data Connection

Hi,

Thanks for your posting and using Aspose.Cells.

We were able to observe this issue by opening the output excel file in Microsoft Excel 2013. The output excel file opens fine in Excel 2010 though.

We have logged this issue in our database for investigation. We will look into it and fix this issue. Once the issue is resolved or we have some other update for you, we will let you know asap.

This issue has been logged as

  • CELLSNET-43802 - Excel file corrupts on opening and re-saving and does not open in Excel 2013

Hi,

Thanks for your using Aspose.Cells.

We have fixed the issues (CELLSNET-43799, CELLSNET-43802)

Please download and try the latest fix: Aspose.Cells for .NET v8.5.1.2 and let us know your feedback.

Hi,

I can confirm that the slicer issue is fixed however, the issue with the chart is not fixed.

var wb = new Aspose.Cells.Workbook("PivotMaster.xlsx");
wb.Save("new.xlsx");
There are no errors upon opening the workbook but the chart is blank despite maintaining it's data connection.
The attached screenshot also shows how the design for the chart cannot be changed and just has progress wheels spinning.
This was tested with the latest version (Aspose.Cells for .NET v8.5.1.2) and Excel 2013.
Thanks,

Dale



Hi Dale,

Thanks for your posting and using Aspose.Cells.

We were able to replicate this issue by executing your sample code with your source excel file using the latest version: Aspose.Cells
for .NET v8.5.1.2
. The output excel file opens fine in Excel 2010 but when it is opened in Excel 2013, chart is shown up as totally blank.

We have logged this issue in our database for investigation. We will look into it and fix this issue. Once the issue is resolved or we have some other update for you, we will let you know asap.

This issue has been logged as

  • CELLSNET-43812 - Chart gets blank in the output excel file and does not show up in Excel 2013

Hi,

Please try our latest version/fix: Aspose.Cells for .NET v8.5.1.3

We have fixed your issue "CELLSNET-43812" now.

Let us know your feedback.

Thank you.
Hello,

I can confirm that v8.5.1.3 resolves all of the issues I faced

  1. Lost Workbook data connection
  2. Missing slicers
  3. Blank chart
  4. And errors

Many thanks,

Dale

Hi,


Thanks for your feedback.

Good to know that your issues are sorted out by the new fix. Feel free to contact us any time if you need further help or have some other issue or queries, we will be happy to assist you soon.

Thank you.

The issues you have found earlier (filed as CELLSNET-43812;CELLSNET-43802;CELLSNET-43799;CELLSNET-43792) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.