Free Support Forum - aspose.com

Worksheets Tab scrolled to the right-hand worksheet

I'm using Aspose.Cells to open a workbook, then copy a worksheet (using Worksheets.AddCopy) many times, each time adding data to the copy. It works beautifully.

However, when I save my new workbook, I want it to be positioned on the first worksheet (index 0). So, I set the active worksheet to 0 using Worksheets.ActiveSheetIndex=0. That, too, works fine.

However, the worksheet tabs at the bottom of my workbook are scrolled all the way over to the right, even though the left-most worksheet is the active one. Is there a way for me to set that tab scrolling area so that the left-most worksheets are visible rather than the right-most.

Thank you!

Hi,

Thanks for your inquiry.

Well, your desired worksheet would be set active if you use/set license file in the code before creating spreadsheets or performing your task because you cannot set active your desired worksheet without a licensed version, see the document how to set license for the component: http://www.aspose.com/documentation/.net-components/aspose.cells-for-.net/licensing.html


Just for your knowledge (if you are not familiar) Aspose.Cells provides some specific API for the tasks. For Example, the Aspose.Cells.Worksheets.ActiveSheetIndex property is useful for setting and active sheet in the workbook. Similarly, the Aspose.Cells.Worksheet.ActiveCell
property is used to set / get an active cell in the worksheet.
Moreover, if you want that the horizontal / vertical scrollbars should
be scroll down to adjust the row / column index position and give you a
better view of data or portion of data opening the file in MS Excel,
you may use
Aspose.Cells.Worksheet.FirstVisibleRow and Aspose.Cells.FirstVisibleColumn properties.

Note: All the above APIs are handy and worthwhile, if you are using the licensed version of Aspose.Cells. Moreover, if you are not setting license the last worksheet (extra evaluation warning worksheet) would be displayed/active first.

See the complete topic here:
http://www.aspose.com/documentation/.net-components/aspose.cells-for-.net/activating-sheets-and-making-an-active-cell-in-the-worksheet.html



Thank you.

I am using a licensed version. There is no "extra evaluation warning worksheet" in my workbook. And the worksheet that I am setting active is active.
The problem is with the worksheets tabs at the bottom of the workbook. The tab for the active worksheet is not even showing there. I have to hit the double arrow to move those worksheets tabs over to the left-most worksheet. How can I correct that problem?

Hi,

Could you post your template excel file with sample code here, we will check your issue soon.

Note: no need to send us your license file here.

Thank you.

Hi,

Well, after further investigation, I think you are talking about left most worksheets tab are not displayed (by default) although you may activate a sheet for your requirement. We will support to set the first visible worksheet tab.

Thanks for your patient

Hi,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for considering Aspose.

Please try the attached latest version of Aspose.Cells. We have supported to set the first visible tab with Workbook.FirstVisibleTab API.

Workbook workbook = new Workbook();

for (int i = 0; i < 15; i++)

{

workbook.Worksheets.Add();

}

workbook.Worksheets.ActiveSheetIndex = 6;

workbook.FirstVisibleTab = 0;

Thank You & Best Regards,

That did it! Thank you very much.