We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

XLS to TIFF Conversion Is Missing Cells using SheetRender

Hello,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

We are using Aspose.Cells.dll 4.9.1.5. When converting the XLS to TIFF, some of the cells are missing from the final TIFF. If you look at the uploaded XLS and TIFF files, you will see that the 4th page, the last page, is missing data when compared to how it prints using Excel.

We are using the SheetRender method. The code sample we are using to perform the conversion can be seen in the thread, “SheetRender Creates Blank Pages But Excel Does Not”

Please let us know when we can expect a fix for this issue.

Thank you,

Robert.

Hi Robert,

After an initial test using your template file, I can find the issue you have mentioned. We will figure your issue out soon.

I have logged your issue into our issue tracking system with an issue id: CELLSNET-17484. Once it is fixed, we will let you know about it.

Thank you.

Hi,

Please try the attached version. We have figured your issue out.

Thank you.

Hello,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

This update has corrected the problem with the missing cells. Unfortunately we cannot use it yet because this new version has created some regression problems which I have reported in the thread: “Missing Logo and Fuzzy / Light Text when converting XLS to TIFF using SheetRender.” Once those are fixed, then we can start using this new build.

Thank you.