Xlsb file corrupted when saved first time from aspose workbook


#21

When we did the regression test we found that RepeatItemLabels setting is not working when we save the file to xlsb. When we save in xlsx it is working fine.

pTable.RowFields[index].IsRepeatItemLabels = true;

We use Aspose 19.2.0.0 version in our code.

Please let us know your feedback, and if this is an issue in current version, when the fix would be expected.


#22

@LakshmiAys,
We were able to observe the issue but we need to look into it more. We have logged the issue in our database for investigation and for a fix. Once, we will have some news for you, we will update you in this topic.

This issue has been logged as

CELLSNET-46678 - PivotField.IsRepeatItemLabels is not maintained in output XLSB as compared to XLSX output

#23

@LakshmiAys,

This is to inform you that we have fixed your issue (logged earlier as “CELLSNET-46678”) now. We will soon provide you the fixed version after performing QA and incorporating other enhancements and fixes.


#24

@LakshmiAys,

Please try our latest version/fix: Aspose.Cells for .NET v19.3.6 (attached)

Your issue should be fixed in it.

Let us know your feedback.
Aspose.Cells19.3.6 For .Net2_AuthenticodeSigned.Zip (4.9 MB)
Aspose.Cells19.3.6 For .Net4.0.Zip (4.9 MB)


#25

The issues you have found earlier (filed as CELLSNET-46678) have been fixed in Aspose.Cells for .NET v19.4. This message was posted using BugNotificationTool from Downloads module by Amjad_Sahi


#26

Thank you. We got the latest version 19.4 from Nuget and the issue is fixed. We are still doing regression testing and will let you know if any other issue comes up.


#27

@LakshmiAys,

Good to know that your issue is sorted out the new version. Please take your time to evaluate the latest version/fix in your scenario. If you find any issue, let us know with details. We will check it soon.