We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

XML Export- OK -> XML Import not OK

Hi,

I have a Form - NABTEST.PDF that contains filled-out form fields. This is exported til NABTEST.XML - OK.

I then tried to import the data from NABTEST.XML to NAB-ORG.PDF (empty form) placing the output in NABTEST-filled.PDF - but this does not work. The NABTEST-filled.PDF is still empty.

Please find files attached.

The form is created with Adobe 8 - LiveCycle Designer.

Michael

Dear Michael,

Thanks for considering Aspose.Pdf.Kit.

I tested your templates with the newest release V3.2.0.0 on my platform. Everything is OK. Please check your code according to the following code.

//Export OK
Form form1 = new Form("NABTEST.pdf");
System.IO.FileStream xmlOutputStream = new FileStream("NABTEST.xml", FileMode.Create);
form1.ExportXml(xmlOutputStream);
xmlOutputStream.Close();

//Import also OK
Form form2 = new Form("NAB-ORG.pdf", "NABTEST-filled.pdf");
System.IO.FileStream xmlInputStream = new FileStream("NABTEST.xml", FileMode.Open);
form2.ImportXml(xmlInputStream);
xmlInputStream.Close();
form2.Save();

The output file is also attached, please check it. If the problem remains, please post it here in intail. We will help you until it works.

Best regards.

Hi,

thanks for rour reply - I downloaded the version, and it works...

except from the Radio Button - <txKonRB>02</txKonRB>

Gender - Male / Female - this field is not updated.

Best regards

Michael

Hi Michael,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

I have tested the issue, and I am able to notice the same problem. I will discuss it with development team, and will update you with the status of correction.

Dear Michael,

You are quite right. Sorry for my carelessness. This bug is expected to be solved in the next release. The ETA is about two weeks.

Best regards.

Hi Michael,

The issue has been resolved. If you need this fix before we publish new version, you could download a Beta version(3.2.1.3) of Aspose.Pdf.Kit.dll from this thread: <a href="https://forum.aspose.com/t/125368

Thanks,

The issues you have found earlier (filed as 5847) have been fixed in this update.