We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

6.0.0 Facades.Form constructor always generates exception

I am unable to come up with a combination of using Facades.Form constructor parameters that doesn’t generate an exception.

The stack trace after my code is:

System.Web.HttpUnhandledException (0x80004005): Exception of type
‘System.Web.HttpUnhandledException’ was thrown. —>
System.ArgumentNullException: Value cannot be null.
Parameter name: stream

at System.IO.StreamReader…ctor(Stream stream, Encoding encoding, Boolean
detectEncodingFromByteOrderMarks, Int32 bufferSize)
at
System.IO.StreamReader…ctor(Stream stream, Boolean
detectEncodingFromByteOrderMarks)
at ..a(Stream stream)
at
.…ctor(„ name)
at ”..a(„ name)
at .€…ctor(– font)
at ”..(–
model)
at Aspose.Pdf.Text.FontCollection…ctor( fontsDictionary)
at
Aspose.Pdf.Resources…ctor(Object parent)
at
Aspose.Pdf.InteractiveFeatures.Forms.Form…ctor(Document document)
at
Aspose.Pdf.Document.(

I’m attempting to use Facade in the same way as Pdf.Kit, and I’ve tried multiple forms of the constructor. They all generate the same exception.

Hi Sam,

Thanks for using our products.

<span style=“font-size:10.0pt;font-family:“Arial”,“sans-serif””>I
have tested the scenario and I am able to reproduce the same problem. For the
sake of correction, I have logged it in our issue tracking system as <span style=“font-family:“Arial”,“sans-serif””>PDFNEWNET-29438. We will
investigate this issue in details and will keep you updated on the status of a
correction.

<span style=“font-size:10.0pt;font-family:“Arial”,“sans-serif””>We
apologize for your inconvenience.

Is there any headway on this? Am I correct in my understanding that it
is impossible to perform any PDF-filling operation without being able to
construct this object? If so, how is it possible that this could go a
month and a half without it being resolved? Is anybody actually using this
for anything? Is this a supported product? If not, what product should I
instead be using to achieve PDF-filling?

Hi Sam,

I just have tested a scenario where I have tried adding some form fields to an existing PDF document while using Aspose.Pdf for .NET 6.2.0 and I am unable to notice any problem. Can you please try using the latest release version of Aspose.Pdf for .NET 6.2.0 and confirm that the issues are actually resolved. In case the problem still persists, please share the code snippet along with sample PDF document. We apologize for the delay and inconvenience.

I have used the code snippet shared over Add Form Field in an Existing PDF file (Facades)

I wish I had been notified (like you said you would do). There has been
two releases since this post, one in August and one over a week ago.

I agree that using the latest 6.2.0 DLLs, the Form constructors seem to work now.

The issues you have found earlier (filed as 29438 ) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.

The issues you have found earlier (filed as PDFNEWNET-29438) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.