Free Support Forum - aspose.com

64 bit problem

Hello,

I'm evaluating your Words/Cells/PDF components but when I publish my application to a machine running 64 bit windows I get the following error:

is not a valid Win32 application. (Exception from HRESULT: 0x800700C1)

Where can I find the 64 bit version, or atleast a version compiled for "any cpu"?

Best regards
Kenneth

Please give me full information on the version of .NET installed on the machine running Win64.

If it is .NET 2.0 then is it for x64 CPU?

When I look in C:\WINDOWS\Microsoft.NET folder I have the following folders:

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727
C:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727

It's a HP Proliant DL385R AMD Opteron 2.2Ghz with Windows 2003 64bit Standard.

My application runs fine on my 32bit windows xp, but as soon as I try it on the 64bit server I receive the error. When I remove the references to the aspose components the application works on the 64 bit server.

I have attached a screendump of the full error.

Regards
Kenneth

miklovan,

Have you been able to reproduce the problem? Our project is going live at the end of this Month and I would like to use your component over softartisans thanks to your nice pdf integration, but if it's not possible to run your component on 64bit platforms we have to go with softartisans officewriter. Can you please give me an estimated timeframe for a fix?

Best regards
Kenneth

Unfortunately we don't have test environment to deal with this problem right now.

Please wait until Monday when I will be able to setup Win64 config and search for some fix or workaround.

I have tested applications which use Aspose.Words under WindowsXP Professional x64. They are working correctly although there are several known issues with ASP.NET x32 applications under IIS x64. They all can be worked around however.

Please provide more details on how you develop and deploy your application.

I am just trying to run the demos from their default installed location and im getting the

"is not a valid Win32 application. (Exception from HRESULT: 0x800700C1) "


Problem.


– Sal

Please describe step by step your actions so that I could reproduce them as close as possible.

You have WindowsXP x64 with .NET 2.0 installed. Is .NET 1.1 installed also?

Then you setup Aspose.Words.

The demo folder contains only source code, demo projects are not compiled yet. How do you compile them? Do you have Visual Studio 2003 or Visual Studio 2005 on your machine, or both?

After compilation you run Windows.Forms demos. Are they working or do they give you an error?

How do you run web demos? Do you run them from studio or config them in IIS or simply enter address in Internet explorer?

And so on - please give as much information as possible. It will help to locate and resolve the problem faster.

Best regards,

miklovan:

Please describe step by step your actions so that I could reproduce them as close as possible.

You have WindowsXP x64 with .NET 2.0 installed. Is .NET 1.1 installed also?

Then you setup Aspose.Words.

The demo folder contains only source code, demo projects are not compiled yet. How do you compile them? Do you have Visual Studio 2003 or Visual Studio 2005 on your machine, or both?

After compilation you run Windows.Forms demos. Are they working or do they give you an error?

How do you run web demos? Do you run them from studio or config them in IIS or simply enter address in Internet explorer?

And so on - please give as much information as possible. It will help to locate and resolve the problem faster.

Best regards,



I 1st went to the main downloads section and dled the latest version 3.7.1.0

I installed it

Opened VS 2005 [ just vs2k5 is installed ] and tired to compile it. I would not compile till i add the " Charts " dll.
I added it and the compile was good.
Next went to IE and opened the demos URL by going to: " http://localhost/Aspose.Words.Demos/ "
upon opening that page i get the " is not a valid Win32 application. (Exception from HRESULT: 0x800700C1) " error.

For the winforms. Opening them up in VS2005 then building them. Then I have to set the " cpu " to x86 because the JET driver does not run on 64bit. After that it runs fine and loads word.

System Specs:
Windows Xp64bit
.NET 2.0
IIS is running in 64bit mode
.NET 1.1 is installed but not enabled in IIS

-- Thanks for your help! Sal

Thanks for additional info. Please give me some more time - I will be able to give you a qualified answer on Monday.

Meanwhile, please try to enable .NET 1.1 on IIS. Aspose.Words is a .NET 1.1 assembly and it won't be able to run without setting permission for .NET 1.1 assemblies in IIS.

Best regards,

Well, there seem to be quite a lot of problems when deploying ASP.NET applications made in VS 2005, and especially in x64 environment.

Here is what I have found so far:

To enable running 32-bit ASP.NET applications in WindowsXP x64 you need to put IIS in 32-bit mode by running the following script from command line or Windows XP Start | Run menu: cscript %SystemDrive%\inetpub\AdminScripts\adsutil.vbs set w3svc/AppPools/Enable32bitAppOnWin64 1

Check the following discussion to get more info about the problem:

http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=588740&SiteID=1

After that you will be able to view the application in the browser, but you can encounter the miscellaneous Server Parser errors. They are cause by IIS giving your ASP.NET application to ASP.NET 1.1 and ASP.NET 1.1 does not understand some of ASP.NET 2.0 pages synax. In IIS 5.1 it could be easily solved by choosing proper ASP.NET version for your virtual directory as described here:

http://vittoriop77.blogspot.com/2006/03/unrecognized-configuration-section.html

But in IIS 6.0 this option simply does not exist due to unknown reasons.

The only reliable way that I have found to ensure that ASP.NET 2.0 will handle all ASP.NET requests in IIS is uninstalling .NET 1.1 from computer Sad [:(].

One more step is setting default.aspx as a default content page for your virtual directory. That can be done as shown on attached screenshot.

Please try this and inform me of the results.

Best regards,

Since I dont have the ties with 3rd party software that requires 64bit .net… I was able to get aspose.words working like this.

uninstalled .net 2.0 64bit by:
1. open cmd prompt
2. running: C:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727>aspnet_regiis.exe -u

After that, no .NET verison was registered with IIS

then I ran the script::

cscript %SystemDrive%\inetpub\AdminScripts\adsutil.vbs set w3svc/AppPools/Enable32bitAppOnWin64 1

^ that enabled 32bit to be ran on iis … it also should have disabled 64bit so dont try to install them.

then I ran:::

C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322>aspnet_regiis.exe -i -enable
and
C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727>aspnet_regiis.exe -i -enable


though the .net 2.0 gave an error at the end… everything seems ok.

– Sal

Thanks for the tip on regiis.exe. I have not known about this.

All in all, the trick is clear - the ASP.NET applications made with VS2005 and using 32-bit dlls such as Aspose.Words should be served by .NET 2.0 32-bit. Such applications cannot run in 64-bit IIS mode. They also cannot be served by ASP.NET 1.1 because it cannot handle ASP.NET application files properly.

So IIS should be put in 32-bit mode by running:

cscript %SystemDrive%\inetpub\AdminScripts\adsutil.vbs set w3svc/AppPools/Enable32bitAppOnWin64 1

And ASP.NET 2.0 should be registered to serve ASP.NET applications on this machine by running:

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727>aspnet_regiis.exe -i -enable.

So have you managed to create documents with Aspose.Words.Demo after all? What was this error in the end that you have mentioned?

miklovan:

Thanks for the tip on regiis.exe. I have not known about this. The trick is clear - the ASP.NET applications made with VS2005 should be served by .NET 2.0 32-bit. That is achieved by running C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727>aspnet_regiis.exe -i -enable.

So have you managed to create documents with Aspose.Words.Demo after all? What was this error in the end that you have mentioned?



Yea the demos work fine now..

the error started here::

Starting Reading the registry: Software\Microsoft\ASP.NET\2.0.50727.0/DllFullPath
Failure Reading the registry: Software\Microsoft\ASP.NET\2.0.50727.0/DllFullPath: Reading the registry: failed with HRESULT 80070002: 'The system cannot find the file specified. '

Dont really know what that means but.. everything seems to be working fine.

-- Sal

And at what moment exactly does this error occur? Does it occur every time you run application or only sometimes? Is there any pattern in when this error happens?

Please provide more information. It could be useful for other users as well.

Sure no problem. All this should get me a free copy right :wink: … LOL j/k

This happens right at the end, after you run::

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727>aspnet_regiis.exe -i -enable

It just says the process had errors and gives you the location of the log file to go read.

– Sal

It sure can Smile [:)]. Have you read about our MVP program start?

http://www.aspose.com/Community/forums/53366/ShowThread.aspx#53366

Ok, so the error happens with aspnet_regiis, not in the demo. That's better.

If you have any further problems with WinXP x64 or .NET 2.0 please let me know. As more and more users are switching to x64 platform I think we need to put more attention to the issue. We will probably add a how-to article to our Wiki on this topic soon.

Kind regards,

naww… whats this MVP Program? that link was bad?

- Sal

miklovan:

It sure can Smile [:)]. Have you read about our MVP program start?

http://www.aspose.com/Community/forums/53366/ShowThread.aspx#53366

Ok, so the error happens with aspnet_regiis, not in the demo. That's better.

If you have any further problems with WinXP x64 or .NET 2.0 please let me know. As more and more users are switching to x64 platform I think we need to put more attention to the issue. We will probably add a how-to article to our Wiki on this topic soon.

Kind regards,

Strange, the link opens ok from my computer. Please try again.

nope sorry::

Not Found: Forum Not Found

The forum you requested does not exist



-- Sal