ActiveX component can't create object

I just now downloaded and installed the trial of Cell. sI am having trouble starting Excel 2007, I get the message "ActiveX component can't create object".

I've tried this on two machines: One machine has XP, one has Vista. Both have Excel 2007 and both give me the same message.

I have Visual Studio, and as a test, created a new applcation and added "Aspose.Cells.ReportingServices.Client.dll" to my references and ran the project (not that the project did anything except compile and run). No problems.

In Excel, I tried adding "Aspose.Cells.ReportingServices.Client.dll" and/or "Aspose.Cells.ReportingServices.dll" to the references, and Ecel says "can't add a reference to the specified file". Same message on both machines.

..This just I was sending this post, I clicked on the RELATED tab, and found a link to <A href="</A></P> <P> which suggested running regasm. This also worked for me. Still not sure why two machines have issues with the installation, but I am up and running. Thanks!</P> <P> </P>


Yes you did fine as we recommend you to re-register Aspose.Cells.ReportingServices.Client.dll using Regasm.exe utility, see the document for reference:

Thank you.