We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Adding comments

I am attempting to add a Comment but it does not display on the web page.

It exists when I search for it in the Immediate window of VS:
Search:
this.ucGridWeb.WebWorksheets[1].Comments.GetComment(this.ucGridWeb.WebWorksheets[1].Cells[“I28”])
Result:
{Aspose.Grid.Web.Data.WebComment}
base {Aspose.Grid.Web.Data.CellAttachObject}: {Aspose.Grid.Web.Data.WebComment}
Note: "WILL THIS WORK?"

But does not appear when rendered to the web page.

Am I not setting a property correctly.

Any input would be greatly appreciated.

Thanks.

Hi,

Yes, you are right. I have tested it with the latest version:

<a href="">Aspose.Cells for GridWeb v2.6.4.2000</a><br><br>And I was able to reproduce it. Below is my sample code.<br><br>This issue has been logged as <a id="key-val" rel="11060" href="http://nanjing.aspose.com:8080/JIRA/browse/CELLSNET-40015">CELLSNET-40015</a>.<br><br><b>C#</b><br><div class="csharpcode">

WebWorksheet webSheet = this.GridWeb1.WebWorksheets[0];

WebCell webCell = webSheet.Cells[“A1”];


WebComment comment = webSheet.Comments.AddComment(“A1”);

comment.Note = “Hello Aspose!”;


this.GridWeb1.WebWorksheets.SaveToExcelFile(“F:\Shak-Data-RW\Downloads\GridWebOutput.xlsx”, FileFormatType.Excel2007);


Hi,


I tested with v2.6.4.2000, it works fine.

Here is my sample code:

int row = 1;
int column = 1;
WebCell cell = GridWeb1.WebWorksheets[0].Cells[row,column];
WebComments comments = GridWeb1.WebWorksheets[0].Comments;
WebComment comment = comments.AddComment(cell);
comment.Note = “This is my comment”;

When I export the file to Excel, it has comment on B2 cell.


Thank you.

Hi,

The comment is not showing up in web page. It does show in output xlsx file.

Hi,


It is showing in the web page, I am using the “WebCells” GridWeb’s featured demo page, it is fine. See the screen shot below.

Hi Guys,

Thanks for all your attention to this matter.

It looks like the error is due to the javascript files not being properly referenced.

If acwmain.js is not found, comments will not appear.

This brings up another issue:
I set the following in the config file:

I noticed that the generated script references do not use the setting. I know the setting is being read because the css link is reading the setting and is now correct:
but the references to the js files are still incorrect

I had to manually add the js references to the page and now the comments work.

In addition, in IE I am getting the following error:

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET4.0C; .NET4.0E)
Timestamp: Fri, 21 Oct 2011 17:40:10 UTC


Message: Access is denied to: file:///C:/Program%20Files/Aspose/Aspose.Grid/agw_client/commonbehav.htc
Line: 0
Char: 0
Code: 0
URI: http://localhost:3409/ViewFinancialStatement.aspx?lid=D5262F13-0AFD-43C2-8DDC-AB96BE5D8BB9


Message: Access is denied to: file:///C:/Program%20Files/Aspose/Aspose.Grid/agw_client/commonbehav.htc
Line: 0
Char: 0
Code: 0
URI: http://localhost:3409/ViewFinancialStatement.aspx?lid=D5262F13-0AFD-43C2-8DDC-AB96BE5D8BB9

Is there any way to set the path for these htc files? I would rather not have to create and give rights to that folder on the server.

Thanks again.


Hi,


Good to know that your comments are now working fine.

For your other issue “Access is denied”… Please check if there is a virtual directory named “acw_client” at IIS root. All these .htc and .js files resides in acw_client (at your GridWeb’s installation directory ) Alternatively, You can change your configuration as this line accordingly:
.
Your application should work fine.

Thank you.

Great thanks.


Are you going to open an issue regarding the “aspose.cells.gridweb.acw_client_path” issue?

Hi,


No, I don’t find this issue on my end. I provided you some suggestion to cope with it if it works fine on your end.

Thank you.

I don’t understand.


Are you saying that when you set the “aspose.cells.gridweb.acw_client_path” in the config file both the javascript files and the css files are referenced correctly?

My tests indicate otherwise.

Hi,
See the following:

Please also make sure that you also set GridWeb's force_script_path and forcepath to "true".

If you still find any issue, please create a sample project, zip it and post it here, we will check it soon.

Thank you.

Hi,

Please try the latest fixed version v2.7.0.2003 for GridDesktop control, currently we have fixed the bug “when user double click some rows , there is an error occur”.

Thank you.

The issues you have found earlier (filed as CELLSNET-40015) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.