We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Adding to a document template but not being able to display the field

Hi,

I am using a template in a word doc. It already has fields that are working but when I add a new field to the table that I am passing to the document it seems to not want to display this field but will display a previous field in its place. I know the datafields are there in the table and have values.

Here is the document I am using for testing. When I add the last two lines is where the problem is.

Percent: «TableStart:CustomerRating»«MinimumEarnedPremium» %«TableEnd:CustomerRating»

Amount: «TableStart:Policy»«minimumEarnedPremiumAmount» «TableEnd:Policy»

Percent Amount: «TableStart:Policy»«stateFeePercent» %% «TableEnd:Policy»

Value Amount: «TableStart:Policy»«stateFee» «TableEnd:Policy»

Here is the output:

Percent: 25 %

Amount: $12,418

Percent Amount: $12,418 %%

Value Amount: $12,418

You can see what it is doing from the results. Any tips on where to go would be appreciated.

Thanks,

Robert

Please check the actual field names. Text like «stateFee» may not be reflecting the actual name of the merge field. It can actually be stateFeePercent instead. Press Alt-F9 in MS Word to toggle field codes viewable.

Best regards,

Dear Vladimir,

That fixed it as when I looked at the fields they were referencing the previous field, hence the repeat. When I changed the merged fields it all worked fine.

Thanks for your help.

Warm Regards,

Robert