We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

After click on submit data dissappears with tomee in OS Linux

After clicking on submit, the data from gridweb dissappears on O S Linux using Tomee Tomcat as server.
emptyGrid.PNG (12.9 KB)

@nenciuioa,

Could you please share sample project and sample files to reproduce the issue, we will check it soon.

When I test from my local pc on localhost (I am using Windows) it works fine.

@nenciuioa,

Could you please share complete environment details where it is not working?

the environment details are:
Java: OpenJDK Runtime Environment, 11.0.17+0-suse-3.49.2-x8664
Server: Apache Tomcat/9.0.68
on OS: Linux

I also attach here a part of what i use from gridweb in my projectproject.7z (270.2 KB)

@nenciuioa,

I checked your sample project a bit and found you are using some older version of the API including acw_client resource files. We recommend you to kindly try using our latest version (Aspose.Cells.GridWeb for Java v23.1) with latest resource files in acw_client folder. You may download our latest demos of Aspose.Cells.GridWeb for Java and give it a try. Let us know if you still find the issue on linux OS.

I tried with changing the acw_client files with the new ones, also the version of gridweb is 23.1.
There is still the same issue on Os Linux.

@nenciuioa
can you provide the whole project which can reproduce the issue.
I can not run the file gridwebNodes.xhtml.
you 'd better try reproduce the issue in our demo page.
with the simplest code