We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Animations in Slides for Java not preserved

Hi,

we are using Aspose Slides for Java Version 17.1 to clone slides containing tables and charts and fill them with data, which works fine.

However, now the tables and charts of the final presentation should be animated. We added those animations to the tables and charts of the template and they are preserved and working for the tables. They are also preserved for the charts but unfortunately not working in the saved presentation

We tried to add the animations programmatically via the API, which is working fine for the charts. For the tables, however, there seems to be no appropriate API function to add animations.

Applying the table animations in the template and adding the chart animations programmatically does work, but seems no solution for us, since they are in the wrong order then and we couldn’t find a method to rearrange the animations via the API.

Any idea how to solve that issue?

Thanks,
Manfred

@MHoefert,

I have observed your comments. Can you please share source files, sample project, and generated result with us. Also please share which Aspose.Slides version you are using on your end and environment details with us so that we may further investigate to help you out.

Muhammad,

I was able to strip down the code to a very simple example to reproduce the behavior. How can I upload the source files?

Regards,
Manfred

@MHoefert,

You can zip and share the sample project in this thread. If that exceeds 5 MB, you can share that on some FTP server or Dropbox link and provide download link to us.

Mudassir,

this is the source code to reproduce the issue:

import com.aspose.slides.Presentation;
import com.aspose.slides.SaveFormat;

public class Create {
    public static void main(String[] args) {
        Presentation pres = new Presentation("Test.pptx");
        pres.save("Test1.pptx", SaveFormat.Pptx);
    }
}

The source and result PPTX files are in the zip archive:

PowerPoint.zip (82.1 KB)

The source file has “on click” - animations on both objects, table and chart. For the saved file the animation is preserved for the table, but not for the chart.

We are currently using aspose-slides-17.1, but the issue can be reproduced with aspose-slides-17.7 as well.

Regards,
Manfred

@MHoefert,

I have worked with the presentation file shared by you and have been able to observe the issue specified. An issue with ID SLIDESJAVA-36571 has been created in our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be automatically notified once the issue will be fixed.