ArgumentException: FontFamily 'Segoe UI' not found error after updating Aspose.Tasks (Java)


After update ASPOSE.Tasks Java from version 18.7 to 19.10. We starts are occuring the following error when trying to convert MPP file to PDF:

java.lang.RuntimeException: class com.aspose.tasks.private_.Exceptions.ArgumentException: FontFamily 'Segoe UI' not found
Parameter name: Segoe UI
com.aspose.tasks.private_.c.j.a(Unknown Source)
com.aspose.tasks.private_.c.j.<init>(Unknown Source)
com.aspose.tasks.private_.c.j.<init>(Unknown Source)
com.aspose.tasks.cix.a(Unknown Source)
com.aspose.tasks.cjc.a(Unknown Source)
com.aspose.tasks.biv.a(Unknown Source)
com.aspose.tasks.biv.c(Unknown Source)
com.aspose.tasks.biv.<init>(Unknown Source)
com.aspose.tasks.bit.<init>(Unknown Source)
com.aspose.tasks.t.<init>(Unknown Source)<init>(Unknown Source)
com.aspose.tasks.aa.b(Unknown Source)

We are using macOs Mojave 10.14.6 on our development environment and CentOS 7.6.1810 our test environments. This error starts occuring on both environments, we didin’t made any changes to code.

This is the sample code:

		PdfSaveOptions saveOptions = new PdfSaveOptions();
		saveOptions.setTimescale(Timescale.Days);, saveOptions);

We’ve tried setting default font:


But this didn’t work.

I’ve shared MPP project that we trying to convert to pdf. It’s empty cause we only want convert to pdf. (24.9 KB)


I have worked with the sample file shared. An issue with ID TASKSJAVA-1024 has been created in our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be notified once the issue will be fixed.

Could you also tell me what exactly version of Java was used to compile ASPOSE.Task 19.10?
I need to know major and minor version.
E.g. 1.8.0_131


I like to share that the issue has been logged for investigation and resolution in our issue tracking system. We request for your patience till the time the investigation is completed and further feedback is shared. We will share the feedback with you as soon as it will be shared.

Hi, any updates? I see that this issue is still in Open status. We cannot use ASPOSE.Task because of this bug :slightly_frowning_face:

Can you increase priority of this bug?


I have verified from our issue tracking system and regret to share that the issue is unresolved at the moment. I request for your patience till the time the issue gets resolved. If you ought to avail prioirity support option, we offer paid support service that you may consider on your end.

Hey again,

the underlined issue is a huge blocker for the performance of our tool. We are getting many problems because of it. Hence I have three requests:

  1. Please speed up the process of issue solving. More than one month has passed and there is no progress. It’s nonsense that you propose a paid support service without resolving the pending issue. It’s generally okay to propose extra services but only after everything is fixed. I am afraid this kind of attitude from your side may cause you a PR fire situation.
  2. We need to have clear time estimates when the issue will be resolved. “I request for your patience till the time the issue gets resolved.” doesn’t work for us, we need numbers.
  3. Please share with me the email address of the tech support team lead/manager with whom we can discuss the case and make sure it won’t happen again.

We look forward to hearing from you shortly.


We understand your concerns and are sorry for your inconvenience. We have increased the priority of the issue and will get back to you as soon as the issue will be addressed.

The issues you have found earlier (filed as TASKSJAVA-1024) have been fixed in this update.