We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Array Formula not calculating

Hi

I am using Aspose 7.1.1.2 and I have an Array Formula in one of the cells and when I do workbook.CalculateFormula(), the calculation doesn’t happens, if I run “calculate now” from excel it works fine. Please find the attached sample excel sheet “SampleForAspose.xlsx”. The array formulas are in the column U1, V1,W1,X1, U2,V2,W2,X2. I also tried 7.3.0.3. It didn’t help. Any help appreciated.

Thanks & Best Regards
Saran

Hi,

Thanks for your posting and using Aspose.Cells for .NET.

We have tested your issue with the following code using the latest version: Aspose.Cells
for .NET v7.4.3.5
and found the issue.

After the calculation, we are getting the empty strings in cell U1, U2, V1 and V2 etc.

We have logged this issue in our database. We will look into it and resolve the issue. Once the issue is resolved or we have some other update for you, we will let you know asap.

This issue has been logged as CELLSNET-41747.

C#


string filePath = @“F:\Shak-Data-RW\Downloads\SampleForAspose.xlsx”;


Workbook workbook = new Workbook(filePath);


workbook.CalculateFormula();


Worksheet worksheet = workbook.Worksheets[0];

Cell cell = worksheet.Cells[“V1”];


//Empty string

string str = cell.StringValue;

Hi Shakeel

Was just curious to know if there are any updates? Even though I have posted as an individual, actually this is for a licensed account Mercer is the company name and if required i can give you the purchase order number.

Thanks
Saran

Hi,

Thanks for your posting and using Aspose.Cells for .NET.

Please spare us some time to fix this issue. Once, we will have some fix for this or some update relating to it, we will let you know asap.

Hi,


Please try the new fix/version: Aspose.Cells for .NET v7.5.0.1, we have fixed your issue now.

Thank you.

Thanks, it is working fine now.

Hi,

Thanks for your posting and using Aspose.Cells.

It is good to know that your issue is fixed with the latest version. If you face any other issue, please feel free to let us know, we will be glad to help you further.


Hi Shakeel

I am having a different issue, I am not sure if I should open a new thread. Here is the problem, I have a 20 mb workbook in memory stream and when I use Workbook.open(ms) it throws an system.stackoverflowexception exception code -532462766. It seems something similar to the problem they faced with aspose pdf

Hi,

Thanks for your posting and using Aspose.Cells.

For your newer issue, please create a separate thread. It helps to sort out your issue quickly. Please also attach the source file and sample code replicating this issue with the latest version: Aspose.Cells
for .NET v7.5.0.1
.

We will look into it and help you asap.

The issues you have found earlier (filed as CELLSNET-41747) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.