We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Arrowhead do not appear in Linux environment

Hi. I’ve noticed there is a problem when trying to convert excel chart that contains arrow to html. In windows environment everything works fine but the problem occurs in linux environment. Arrowhead is missing. I’m using linux debian. I’m sending you code written in .net core together with simple .xlsx example that can be found in examples folder. Also, in " bin\Debug\netcoreapp3.1\Outputs" folder when you run project you will get html output that is rendered using aspose.cells library. I’ve used latest version of aspose.cells 21.7.0. I’m also attaching outputs both rendered in windows and linux.

example_unix.png (16.9 KB)
example_windows.png (15.8 KB)
AsposeBug.zip (115.3 KB)

@ottap,

We tested your scenario/ case in our Linux environment and could not find the issue. We used latest version/fix, kindly try our latest version/fix: Aspose.Cells for .NET v21.7.6:
Aspose.Cells21.7.6 For .Net2_AuthenticodeSigned.Zip (5.6 MB)
Aspose.Cells21.7.6 For .Net4.0.Zip (5.6 MB)
Aspose.Cells21.7.6 For .NetStandard20.Zip (5.6 MB)

Let us know if you still find any issue. Moreover, please make sure the following libraries are installed in your linux.
libgdiplus:

apt-get update
apt-get install -y libgdiplus
cd /usr/lib && ln -s libgdiplus.so gdiplus.dll

libc6-dev:
apt-get install -y --no-install-recommends libc6-dev

Hello @Amjad_Sahi,

did you try it with demo code in .NET core that I attached here? I’m using .NET Core in Linux so aspose cells for java does not help.

@ottap,

Sorry I meant Aspose.Cells for .NET. I have fixed my previous post and re-attached the latest fix of Aspose.Cells for .NET Standard, so you may try it.

1 Like

Thanks. I’ve tried with .netstandard version 21.7.6 you provided and also checked that I have all libraries installed. And they were already installed. I’ve got the same issue. So, you are not missing this arrow “pointer” in linux environment that I’ve marked with green square in image attached to this post?Chart.png (45.3 KB)

@ottap,
We have tried your sample code and here is the output of this program that shows the arrowhead in the output HTML file.
example_Unix 19.6.0.0.html.zip (9.4 KB)

For further investigation please share your complete environment details for our reference. We will try to reproduce the issue by establishing a similar environment.

@ahsaniqbalsidiqui
Sure. Operating system that we use is debian gnu linux 10 (buster) 64 bit. Maybe the best way to establish similar environment is to use WSL2 on windows machine and debian linux distribution. Do you need some additional information?

@ottap,
Thank you for sharing more information. This issue is reproduced and logged in our database for further investigation. You will be notified here once any update is ready for sharing.

This issue is logged as:
CELLSNETCORE-136 - Arrowhead does not appear in Linux environment

1 Like

Hi @ottap
Please use our latest patch, we have optimized for this problem, please let us know your feedback.
Aspose.Cells21.8.1 For .NetStandard20.Zip (5.6 MB)

Hi @leoluo,

I confirm that the bug is resolved with this patch. Thank you!

@ottap,

Thanks for your feedback and good to know that your issue is resolved by the new fix/version. In the event of further queries or issue, feel free to write us back.

The issues you have found earlier (filed as CELLSNETCORE-136) have been fixed in this update. This message was posted using Bugs notification tool by simon.zhao