We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose.BarCode 2D Data Matrix displayed as Red X

Currently attempting to use Aspose.BarCode on a SQL/SSRS 2014 install using Aspose.BarCode 7.7.0 (in evaluation, because our license needs to be renewed).

In our RDL files, two render as expected (Data Matrix with “Aspose” interspersed), one (which is configured in an identical fashion) is not rendering, instead showing as the "Red X"


How do I modify this RDL to not show the Red X on preview? Is there a way to review rendering errors on preview?

Hi J.D.,

Can you please share your input file to reproduce the issue? Sorry for the inconvenience.

Best Regards,

Hello Muhammad,

Attached is the file that is having trouble in the SSRS 2014 environment.
Note, in the VS2010 environment in which this is developed (using a different version of the DLL/XML/config) and we currently have the license, there are no issues.

Other RDLs using Aspose.BarCode in our SSRS 2014 environment are not having this issue, either. Just the attached.

Hi J.D.,

We will test the issue with SSRS 2014 and share our findings with you soon.

Best Regards,

Hello,

Is there an update to this case?

Hi J.D.,

Sorry for the delay. We are preparing the same environment at our end and have raised the priority of this issue. We will update you soon.

Best Regards,

Hello Muhammad,

I was able to find a solution; apparently, the rendered barcode on the RDL needs to have just the right sizing on the textbox to actually render an image on SSRS. Somehow this got broken when modifying the RDL file.

Hi J.D.,

Good to know that the issue has been resolved and thanks for sharing the details with us.

Best Regards,