Free Support Forum - aspose.com

Aspose.CAD cant read some dwg files


#1

Hi, I´m evaluating trial version of aspose.cad and I tried to open few files that I found on my disk. It failed to open roughly 30% of them.
I get exception: Cannot process loading further due to incorrect file format structure.

I attached one of the files. Can you please check it? (I can open this file with any CAD application without any issues)

Hotel Mineral.zip (474.6 KB)

thank you
Petr


#2

@petr.mahdalicek,

I have observed your requirements and suggest you to please share the sample code used on your end to reproduce the issue. Please provide the information so that we may proceed further to help you out.


#3

this is the code:

Image.Load(fileName);


#4

@petr.mahdalicek,

I have worked with the DWG file shared and have been able to observe the issue specified. An issue with ID CADNET-728 has been created in our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be notified once the issue will be fixed.


#5

thank you.
Will you share with us the reason aspose failed to load this dwg? Is there any way for me to watch progress of this issue? Is there anything I can do to help you?

BR
Petr


#6

@petr.mahdalicek,

We will be investigating and resolving the issue on its due turns and present it is pending in issues ques. We will certainly request your for any information if we require that for resolution of issue. You can only observe the status of issue by observing the status at bottom of page where issue is linked withg the page. It will get change as soon as issue will be fixed. Secondly, we will also inform you as soon as the issue will fixed.