Aspose.Cell error in .Net Standard 2.0 Library


#1

Could not load file or assembly ‘Aspose.Cells, Version=19.7.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56’ or one of its dependencies. The located assembly’s manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

I am getting above in .Net Standard 2.0 type library. I have added Aspose.Cell nuget package reference to the library.


#2

@sachingangarde,
I have tried this scenario by upgrading the library in my sample project using Microsoft.NETCore.App (2.0) to the latest version Aspose.Cells 19.7 but observed no issue. The library is upgraded successfully and sample code executes fine. Please note that after the release of Aspose.Cells for .Net Standard 19.2, a dependency is required for System.Drawing.Common and System.Text.Encoding.CodePages as mentioned in the Dependencies section here. Please ensure that while upgrading the library through NuGet package manager, these dependencies are also installed. If these are not installed, try to install them manually from NuGet package manager.

If still issue is there, please provide us with a newly created sample console project (runnable) with Aspose.Cells code only. We will try to reproduce the issue here and provide our feedback. Also, share the environment details with us.


#3

This does not work by simply adding Nuget packages to .Net standard library type project. When I added explicit reference to Aspose.cells dll, it worked. It doesn’t work simply adding package reference despite having all the dependencies in place.


#4

@sachingangarde,
I have tried this scenario by creating a fresh project and added Aspose.Cells from NuGet package manager. It worked fine and DLL was added successfully. Could you please provide details of your environment and steps to reproduce this issue. I will try to recreate this scenario here and provide assistance accordingly.
Screenshot 2019-07-21 at 11.34.57 AM.png (112.6 KB)