Free Support Forum - aspose.com

Aspose.cell on SQL Server 2012 Installation

I tried to install Aspose.Cells.ReportingServices_18.2 on SQL Server 2016 . The msi routine ends with an error in the eventlogs: error status: 1603.
I tried all the suggested solutions with admin - permission etc. Nothing helps. There is also no drive encryption.
Therefore I installed the DLL-only version as described here: https://docs.aspose.com/display/cellsreportingservices/Using+DLL+Only
But I am not sure which steps of that description have to be executed on the sql Server.
Can anybody help?
thans

@bauh,

Thanks for providing us details.

Could you try our latest version/fix: Aspose.Cells for RS v18.2.6.

Let us know if yous still find any issue.

Hello Amjad
thanks for the version/fix 18.2.6
I tried different ways:

default method with msi:
ACRS18.2.6msiexec_i.zip (53.2 KB)
same result. “Aspose.Cells for Reporting Services 18.2.6.0 Setup Wizard ended prematurely because of an error. Your system has not been modified. To install this program at a later time, run Setup Wizard again. Click the Finish button to exit the Setup Wizard.
The software actually could be found under “Programs and Features”. The Aspose-Directory in “Program Files (x86)” exists. The dll is not copied. The ReportingServices Config Files are not modified.

msiexec.exe /a method:
the installation runs without the possibility for user input. Message: “Aspose.Cells for Reporting Services 18.2.6.0 Setup completed successfully.
The software is installed on drive H:\ProgramFilesFolder\Aspose\Aspose.Cells for Reporting Services. (yes , we have a drive h:)
The dll is not copied. The ReportingServices Config Files are not modified. See logfile for this installation attached.

msiexec.exe /i method :
normal installation. Same result as the default method. See logfile for this installation attached.

Thanks and regards
hp

@bauh,

Thanks for providing us log files.

I have logged a ticket with an id “CELLSRS-537” for your issue. We will investigate and look into it. Once we have an update on it or we figure it out, we will let you know.

@bauh,

We have checked your issue. We installed SSRS2016 on Windows Server 2012R2 and performed test, it works fine on it. Could you provide complete details about your environments, e.g what server platform you installed for Aspose.Cells for RS (Window server 2012R2 or Windows Server 2016)?

Microsoft SQL Server 2016 (SP1-CU8) (KB4077064) - 13.0.4474.0 (X64) Feb 24 2018 13:53:17 Copyright © Microsoft Corporation Standard Edition (64-bit) on Windows Server 2012 R2 Standard 6.3 (Build 9600: ) (Hypervisor)

Windows Server 2012 R2

I also tried the Installation on a Windows Server 2016 and there it worked.

The Problem is, that we Need that tool on the older System with Windows Server 2012 R2.

I will have a closer look to the msi-log file and try to find the reason for the failure.

Any help is appreceated

@bauh,

Thanks for providing us environment details.

We have logged the details against your issue into our database for investigation.

Yes, kindly analyze your issue based on log files if you could find/rectify the issue in your enviroment. Also, post us the log files and details here. We will also try to evaluate your issue thoroughly.

@bauh,

We evaluated your issue further. You need to install .Net Framework 3.5(include 2.0 or 3.0) on Windows Server 2012 R2 to fix the issue.

Hope, this helps a bit.

Indeed. After installing .Net 3.5 the msi could be installed successfully. Can you explain why this is needed? Although it is still supported by Microsoft, we are not happy to install that old piece of software on our production environment. Any chance your installation-procedure will be updated very soon?

@bauh,

Good to know that your issue is sorted out by installing .Net framework 3.5. I have logged your concerns against your issue into our database. We will look into it and update you soon.

@bauh,

I have discussed this matter and want to share that as the custom action section of installation program is developed on basis of .Net Framework3.5(including 2.0 and 3.0) therefore it is required. There is no plan in near future to update this program.

The issues you have found earlier (filed as CELLSRS-537) have been fixed in this update. This message was posted using BugNotificationTool from Downloads module by Amjad_Sahi