We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose.Cells conversion to PDF issue related to Ghostscript

Hi,

We are facing an issue related to Aspose.cells 7.0.4.0 (Framework 2.0) conversion to PDF files, the PDF file generated is processed by another application but it is not able to be processed because application is using Ghostscript V8.15. Also, we tried to use XPS extension filetype, but it doesn't work. We are looking for a solution for this because this is producing two or three hours delay on our production work.

Could you help please?

Thank you,

Danilo Ac

ACS, Inc, a Xerox company

danilo.ac@xerox.com

Hi,

Thanks for your posting and using Aspose.Cells for .NET.

Please download and use the latest version:
Aspose.Cells
for .NET v7.1.2.6

and let us know your feedback.

If the problem still occurs, then please provide us your sample source xls/xlsx files and the output pdf. Please highlight the problematic areas application in a screenshot with red circles.

Please also highlight your problems relating to XPS with red circles in a screenshot and provide us your code example replicating the problem.

We will look into it and help you asap.

Hi,

We updated the aspose.cells dll file, and we still have the same issue, attached files are the source code and error message we got.

The error is produced some times, with specific data, I am not able to send you data example because of privacy of data :( .

For source code, we got the data from SQL query (2 worksheets), and it is send to workshee and try to save with Aspose.cells component, also we tried with Aspose.pdf component (last part of source code).

Also, I tried with saveoptions:

Dim svoptions As New Aspose.Cells.PdfSaveOptions

svoptions.Compliance = Aspose.Cells.Rendering.PdfCompliance.PdfA1b

svoptions.DefaultFont = "MS Gothic"

You may help us with the source code and error message we got from Ghostscript.

Thank you,

Danilo Ac

danilo.ac@xerox.com

Hi,

Thanks for your feedback and testing it with latest version.

We have logged your issue in our database. Development team will look into this issue and help you asap.

Once, we will have some update/workaround/fix for this issue, we will let you know asap.

This issue has been logged as CELLSNET-40570.

Hi,


We checked your issue a bit, we found according to the screen shots you shared with us, the Error file name is “salida.pdf”, which is is generated by Aspose.Pdf product. If so, you should contact Aspose.Pdf team in their forum for your issue:
http://www.aspose.com/community/forums/aspose.pdf-product-family/20/showforum.aspx

If this is not the case and issue is with the Aspose.Cells's generated PDF file, kindly give us your template file(s) (you may fill with some dummy data or click "Keep this post private" check box while replying to this post -- now only you and Aspose staff members can see your attachments, you need not to worry about it) and sample project to show the issue, we will check your issue soon.

Thank you.