Aspose.Cells do not work on Linux Box post Deployment

Hi Support Team,

I am using the latest and stable version of Aspose.Cells and wanted to check functionality for ConvertToPDF feature from (.xlsx->PDF). But I am getting below error from last couple of weeks and its not yet Resolved. Tried all the solutions that I found on web, forums, google etc. I am using .NET CORE C# 3.1 version. Do I need to add any file in Linux Bundle.

image.png (6.6 KB)

Below is the code snippet.
image.png (45.6 KB)

Kindly help me on this and I have a critical deliverables.


It looks like Graphics Library is not installed properly on your linux system. Also, make sure the “EnableUnixSupport” switch is turned on for the purpose. For complete reference, please see and follow the instructions mentioned in the thread to fix the issue.

As suggested Yes, I have installed libgdiplus Package on my Linux Box but still do not work. Where do I need to set “EnableUnixSupport” . I have gone thru the thread mentioned above.


You can enable support for non-Windows platforms in .NET 6 by setting the System.Drawing.EnableUnixSupport runtime configuration switch to true in the runtimeconfig.json file. See the document for your reference.

Done the changes above mentioned in runtimeconfig and also installed libgdiplus on my Linux Box .Thanks for your help I was able to successfully Convert ToPDF from xls and xlsx file.


Good to know that you have sorted out your issue by setting the configurations (as suggested). Feel free to write back if you have further questions or comments.

Hi Support Team,

There is a page where I am adding an Image file in the document for PlaceHolder.
I am not able to add this image file into my generated documents.

There are some of the above mentioned steps that I did on load balancer machine. But still i am getting the same error. EnableUnixSupport,sudo amazon-linux-extras install epel,sudo yum install libgdiplus

I am trying to generate the PDF (.pdf) and Word (docx). on Linux Machine. We have Deployed .net Core project on Linux machine. While generating the documents either PDF or .docx I am getting an error “Error occurred while generating the document the type Initializer for Gdip threw an exception“.

Is there anything I am missing… to install.

Please refer to the following documents: