Aspose Cells for Javascript via Java


Quick question, must Aspose Cells For Javascript via Java work on Mac?
It worked for me on Linux, but not on Mac, any idea why?

Thank you for your answer


This Topic is created by Amjad_Sahi using the Email to Topic plugin.



Thanks for your query.

Apparently, it should work fine on Mac if you have installed relevant node.js for Macintosh installer and node-java bridge.
We have not thorough tested the API on Mac, we will do that soon. I have logged an investigation ticket with an id “CELLSJSJAVA-11” for your issue. We will look into your issue soon.

Once we have an update on it, we will let you know here.



We did evaluate your issue by setting up environment (Mac) and testing Aspose.Cells for JavaScript via Java API. We did find an issue using the component on Mac and we have fixed it now.

We recommend you to install Oracle JDK 1.8 on Mac. When the jdk installation is done, please do as following:

1. Configure JAVA_HOME
2. Change /Library/Java/JavaVirtualMachines/jdk1.8.0_152.jdk/Contents/Info.plist with root privilege (our Oracle JDK version is 8u152)

And, you have to add headless java option into “aspose.cells.js”. Please replace the existing “aspose.cells.js” in node_modules/aspose.cells/lib folder with the attachment: (17.5 KB)

Let us know if you still find the issue.


Cool, thanks, I’ll try that.

Thanks for the support.



@Amjad_Sahi I can’t download the file, it says “Sorry, this file is private. Only visible to topic owner and staff members.”


Forget it, my mistake



Sure, please take your time to test Aspose.Cells for JavaScript via Java on Mac and follow the instructions and replace the .js file as directed in my previous post. Hopefully your issue would be sorted out.


The issue (filed as “CELLSJSJAVA-11”) has been fixed in our latest version/fix: Aspose.Cells for JavaScript via Java 17.12.

This release includes fix for using Aspose.Cells for JavaScript via Java on Mac environment, for more details, see the document for reference: