We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose.Cells.lic ERROR

I get this error when I try to "Setlicense"

Request for the permission of type 'System.Security.Permissions.FileIOPermission, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failedv

using this code:

Dim path As String = HttpContext.Current.Server.MapPath("~")
Dim licFile As String = path & "\Aspose.Cells.lic"
Dim license As Aspose.Cells.License = New Aspose.Cells.License()

license.SetLicense(licFile)

The same code has no problem when I use "Aspose.Words.lic". Aspose.Words.lic and Aspose.Cells.lic are in the same directory that a grant Full Control to Everyone. I use Windows Server 2008 R2. What am I doing wrong ?

I had the same problem some months ago, but with code above I solved, but now on another server I get again the same error !!!

Regards

Stefano

Hi,

I think this type of issue may not have any concern/links with Aspose.Cells product. The error refers to that you don't have enough security permissions to process your IO task. Please assign administrative role to your web application, it should work fine.

I think the best way to replace the component's older dll with new dll file (if you are upgrading to latest version of the product v7.0.3) is to remove the older reference of the product first in VS.NET IDE, now add reference to new/desired dll file in VS.NET, compile and run the project, it should work fine.

If you still find the issue, I am afraid we need the issue to be reproduced on our end as we have not find any such issues. Please create a separate simple application with your license file, zip it and post us via email, see the link on how you will post us the project with license file, we will check it soon.
http://www.aspose.com/corporate/purchase/faqs/send-license-to-aspose-staff.aspx

I followed your advice (I removed the older reference in VS.NET IDE and I added reference to new dll file in VS.NET) and now it works!

Many thanks!

regards

Stefano