We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose Cells Out Of Memory Exception When Opening A Workbook

Hello,

I am getting an out of memory exception when opening an excel workbook file. I have two files, one larger then the other and the larger file works fine, but the smaller file causes the out of memory exception.

I have tried to use the “MemorySetting.MemoryPreference” load option setting, but that has not fixed the issue.

I currently am running on version 8.2.1 on .Net Framework 4.6.2. In the next year or so, we will be upgrading to the most recent version and running on .Net core, but that is months away. Attached is an example project and the files I am having issues with. File1.xlsx works just fine, but File2.xlsx doesn’t and is smaller then the first file. I tried attaching the solution’s zip file, but the UI isn’t working even though I am under the 50k KB limit.

Can you provide any insight into this or am I out of luck because I am running such an old version?

Thanks,
Jamie

@jstoneb3insight,

We are sorry but we cannot evaluate any issue using older version of the APIs. Neither we can include fixes in older versions as the fixes (against issues) are only based on latest APIs set. So, you got to upgrade to latest version and try your scenario/ case. In case, you still find any issue with latest version (e.g. Aspose.Cells v21.5), let us know with details and template Excel file (please zip it prior attaching here) and we will try to figure it out soon.

Thanks for the quick response. That’s what I assumed would be the answer. We will look into upgrading sooner rather then later or a work around until we upgrade.

Thanks