We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose.cells replacing dot with comma for amounts When reading the xls

Hi Aspose Team,

Recently bought Java Aspose cells 21.4 version.
when reading a xls file in the amount column dot is being is replaced with comma
Please help us to resolve this issue

@hruser,

This looks to me due to your locale/regional settings of the system where you are parsing/processing Excel file via Aspose.Cells APIs. Please note, the numbers formatting would be changed in accordance with the locale/regional settings of the system. For confirmation, you may open the template Excel file into MS Excel manually on the system and you will also notice dot is replaced with comma. In case, you still think it is an issue with Aspose.Cells API, kindly do zip your Excel file and provide us, we will check it soon. Also, give us your environment details (server’s OS, locale/regional settings, etc.).

1 Like

@hruser
For xls template file, regional settings may be saved in the file. If the separator for you locale of the environment should be dot but the formatted value shows comma, maybe the locale saved in the xls template file is different from your environment. If it is the case, please change the locale of the workbook(such as by Workbook.Settings.Region/Locale) to the same one with your environment.

1 Like

Thank you for the response, yeah will check the setting in workbook.

@Amjad_Sahi, @johnson.shi
Found that locale is ru_RU for the excel we are trying to read,
That might be the culprit in changing dots to comma.
Thank you for the help.

@hruser,

Yes, your issue might be due to the locale ( ru_RU) set in your template file. In the event of further queries or comments, feel free to write us back.