Free Support Forum - aspose.com

Aspose Cells Reporting Service Client and Excel 2007

Hi, <?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

After installing Aspose Cells Reporting Service Client, when I open Excel 2007, I get next message :

Run-time error ‘429’

ActiveX component can’t create object

Debugger stopped on next line

Set AsposeClientTools = CreateObject("Aspose.Cells.ReportingServices.Client.AsposeClient")

Aspose toolbox does of course not appear in Add-Ins tool bar.

How can I fix this issue?

Thanks

Hi,

Please make sure that you have installed all the .NET and windows patches on you machine. Does the problem only happens in Office 2007 or other Office versions e.g.., 2003, so you may check: http://www.aspose.com/documentation/ssrs-rendering-extensions/aspose.cells-for-reporting-services/automation-error.html

We will look into your issue and get back to you soon.

By the way, which version of the component you are using.

Thank you.

Thanks for your answer, but I can’t solve my problem. <?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

- I downloaded from your Web Site: Aspose.Cells for Reporting Services V1.2.0.0

- I installed Aspose.Cells for Reporting Service s V1.2.0.0 client on three computer having MS Office 2007 (Professional, Small Business, SP1 installed).

- For each computer, I got an error message when MS Excel loads Aspoce.Cells.ReportingServices.Client add-ins:

Run-time error ‘429’

ActiveX component can’t create object

Debugger stopped on next line

Set AsposeClientTools = CreateObject("Aspose.Cells.ReportingServices.Client.AsposeClient")

Is Aspoce.Cells.ReportingServices.Client compliant with Excel 2007?

Following your suggestion, I tried to install Aspose.Cells for Reporting Services V1.2.0.0 client on a XP computer with Office 2003, and I got also an automation error. Even after installing:

- Update to Office 2003 (KB907417)

- Update to Office 2003 SP1

My company has migrate all their computers to Office 2007.

Installing Aspoce.Cells.ReportingServices.Client on Office 2007 should be for us the right way to follow. Any idea to solve the issue on Office 2007?

Thanks in advance.


Hi civies

Please reference to system requirements.

If you did not install .Net framework 2.0 , please try install it.

If the question exists ,please post your system environment.




Hi,

COMPUTER 1<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Windows Vista

Microsoft Office 2007 + SP1

Visual Studio 2005 Team System + SP1 (thus .NET 2.0 Framework is installed)

Visual Studio 2008 Team System + SP1 (thus .NET 3.5 Framework is installed)

I downloaded from your Web Site: Aspose.Cells for Reporting Services V1.2.0.0

I installed on client computer Aspose.Cells for Reporting Service s V1.2.0.0 client

When I open Excel 2007, I have next error:

Run-time error ‘429’

ActiveX component can’t create object

Debugger stopped on next line

Set AsposeClientTools = CreateObject("Aspose.Cells.ReportingServices.Client.AsposeClient")

COMPUTER 2

Windows XP SP2

Microsoft Office 2003 + SP1

Update to Office 2003 (KB907417)

.NET 2.0 redistribuable

Aspose.Cells for Reporting Service s V1.2.0.0 client

When I open Excel 2003, I have next error:

Run-time error ‘-2146232576 (80131700)’:

Automation error

What am I missing on COMPUTER 1 and COMPUTER 2 ?

Thanks.

Hi civies,

Please post installation log file here.

The installation log file in ${installation Path}.

Soon, I will check it.




Hi,

Here follows the content of install.log on Vista Computer:

dimanche 19 octobre 2008 2:40:43 :: Install Desginer
dimanche 19 octobre 2008 2:40:43 :: Create the HKEY_LOCAL_MACHINE\SOFTWARE\Aspose\Aspose.Cells.ReportingServices key
dimanche 19 octobre 2008 2:40:43 :: Get user the key value ,first
dimanche 19 octobre 2008 2:40:43 :: =================Start loading client program ===================
dimanche 19 octobre 2008 2:40:43 :: Check Client Condition
dimanche 19 octobre 2008 2:40:43 :: Register Assembly
dimanche 19 octobre 2008 2:40:43 :: Login Client
dimanche 19 octobre 2008 2:40:43 :: Add add-in Manager of office 8.0
dimanche 19 octobre 2008 2:40:43 :: load 9 8.0
dimanche 19 octobre 2008 2:40:43 :: Loading Aspose.Cells.ReportingServices.Client add-in Manager of office 8.0
dimanche 19 octobre 2008 2:40:43 :: Add add-in Manager of office 11.0
dimanche 19 octobre 2008 2:40:43 :: load 10 11.0
dimanche 19 octobre 2008 2:40:43 :: Loading Aspose.Cells.ReportingServices.Client add-in Manager of office 11.0
dimanche 19 octobre 2008 2:40:43 :: Add add-in Manager of office 12.0
dimanche 19 octobre 2008 2:40:43 :: load 10 12.0
dimanche 19 octobre 2008 2:40:43 :: Loading Aspose.Cells.ReportingServices.Client add-in Manager of office 12.0
dimanche 19 octobre 2008 2:40:43 :: =================Loading client program is over ===================

Hi civies,

I had checked installation log. Installation is normal.

Please check Aspose_Cells_ReportingServices_Client in VBA references . Is Aspose_Cells_ReportingServices_Client normal bind ? If binding is not normal, please check registry info.

Please post all Aspose.Cells.ReportingServices.Client info in registry here.

We had released new version. Please try it.

If new version exits the same question , please post installation log and registry info here.

Thank you for your providing info.



The issue is not occurring anymore with next version: Aspose.Cells for Reporting Services V1.3.0.0. <?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your support.

Hi,

I have this problem too - did you find out what the issue was?

Thanks

Dave

Hi,
<o:p></o:p>

Please refer to the document for Run-time error 429.

If the issue still exists, please post your detailed information here. We will check it soon.

Thank you for your support.