We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose.Cells- Version=5.0.0.0- The system cannot find the file specified

Hello,

First I am a newbie to Aspose and working at this level of detail troubleshooting applications, but here I am. I’d like to have this corrected today. The application is a wrapper that reads from an excel template to a SQL2005 database.

The issue when read is started, “Reading the information failed, unable to write” "Could not load file or assembly ‘Aspose.Cells, Version=5.0.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56’ or one of its dependencies. The system cannot find the file specified."

The specific application related to the error has not been used for 6 months. The last time this application worked .NET 4.0 may not have been installed. Maybe unrelated, I compressed the drive during disk cleanup -n uncompressed to correct an issue with compressed SQL files.

The current version in the application program file folder is v4.1.1.0 - .NET 1.0SP3, 2.0SP2, 3.0SP2, 3.5SP1, 4.0 are installed. Windows Server 2003R2 x32 Standard SP2.

Tried downloading the v5.0.0.0 and swapping with existing file - resulted in same error.

Hi,

Please try the latest version:
Aspose.Cells for .NET v7.0.3.2 and let us know your feedback.

where do I get the latest and how is the latest installed?

Hi,

Please download it from the above link given by me. This is simply a dll (.NET framework assembly). Just add a reference to it in your project and start using it.

I cannot add the link in my project - it is technically not my project, I am the end user. But I am in contact with the developer and this is a Beta so a solution found here should work there.

They have an application that reads an excel file into a SQL database. These are my assumptions for possible causes

  • The version I am using is several years old - it has the beta functions - has the aspose.cells license expired
  • The application uses a 2.0 aspose license and an addon dll is looking for an 2.2 aspose license
  • The aspose error references PublicKeyToken=716fcc553a201e56 and the aspose 2.0 license in the program file has the same token id - is the dll looking for the license in the wrong location, if I moved it to the right location the problem is solved?
This license is for an experiment I am working on as part of my PhD graduate work, if the license is expired, how can I buy a new license or get one to cover us for a few months until the experiment is done - or is that the link you posted above?

Tried several tests:
  • tried adding aspose.cell.dll to gac
  • dragged and dropped aspose.cells.dll to windows/assemblies folder - the public key is not there
  • uninstalling .NET and returning to .NET 3.5 SP1 http://forums.asp.net/t/956018.aspx/1 - the application using aspose.cells is pre 2009

Sorry for the delay responding to your last post, I have been working with the developer to resolve some other issues and we had this problem fixed by using a newer version of their software but that turned into a dead end.

Hi,

First of all check, if the latest version resolves your problem.

You can check it in Evaluation Mode, you do not need a license for it.

If it resolves your problem, then check if the latest version works with the license you already have. If your license has not expired, it will work.But if your license has expired, it will show Evaluation Sheet in the output xls/xlsx files. In this case, you will have to purchase a new license.

To purchase a new license or renew your old subscription, please contact Aspose.Sales team or post in Aspose.Purchase forum. They will help you asap.

I downloaded the msi file for .NET 7.0.4 and installed; the same error appears that assembly aspose.cells cannot be found.

The someApp addon dll wants v5 and I have v4.1 with the base msi install of someApp - so should I install the evaluation v5 msi. But v5 msi is not available for download just the dll are there. So, I tried installing v5.2.2 the last version with an msi for download - then put the v5 .NEt2.0 dll in the someApp program files folder. The eror changed from aspose.cells file not found to ‘unknown error’.

Appreciate your patience

Hi,

You only need the dll and not MSI file.

Anyway, if you have a source code, then I will recommend you to use the latest version and recompile your project.

If you do not have a source code and want to run your existing binary executable, then you have no choice but to provide it exact dll with which it was compiled.

For example, if your exectuable was compiled with v5.0.2.5, then you cannot use v5.0.0.0, you must use v5.0.2.5.

FYI: Please read about Strong Naming and Versioning in .NET Assemblies.

Hi,

Please check whether your target .Net frame is 4.0 or 4.0 client profile.

I do not have access to the sourcecode

1) how do I check if target .Net frame is 4.0 or 4.0 client profile.?

2) I downloaded the v5.0.0 dll - there are three folders, net_clientProfile, net1.1, and net2.0 - each has some dll and an exe; what do i do next?

Hi,

I think, you can check it using Visual Studio 2008 or 2010 as shown in the following screenshot.

If your version is not clientprofile version, then you will use the dll inside the .net2.0 folder. In case, it is a clientprofile, then you will use the dll inside the clientprofile folder.

For the following screenshots, you will use the dll in .net2.0 folder.

Screenshot:

in Visual Studio 2005 it is version 2.0.50727 SP2

I need a few more details for what to do with the dll - 'If not clientprofile, then use the .net2.0 dll’

what do you mean by ‘use’? Do I take the contents of the .net2.0 folder and drop them in the same folder as the program file?

And,
'if your executable is compiled with v5.0.2.5, then must use v5.0.2.5. '

how do I check what executable version is compiled - the error message gives v5.0.0.0



Hi,

You should use .NET 2.0 dll for your needs. Just ignore other dlls.

Then update the reference to your existing dll with this new 2.0 Aspose.Cells dll.

Please see the screenshot how to add assembly reference.

Once, you have added a reference, then compile it, if you get some errors while upgrading your code, then fix them or post here, we will help you asap.

I do not have access to the source code

Hi,

You should then use v5.0.0.0 found in .NET 2.0 folder.

Just for feedback and a conclusion to this thread; your advice and help, unfortunately did not help.

The developer found some free time and rewrote the application sourcecode. From your advice I was never able to use the aspose.cells trial version. I think you are assuming I understand or know some details that I do not since your advice was cryptic at best and misleading at worst.

Hi,

Thanks for your feedback. I am sorry, the thread was not much helpful for you.

Actually, when you build an application in .NET with some specific version, then you cannot use any other version. I guess, there are some ways to do it, but you will need to do research how to know the version of the assembly when application has already been built and how to change the version of the assembly in already built application into some other version.

The best approach was to rebuild the application from source code.