We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose DependencyResolutionException

Hi all, I am currently getting an error when building my pipeline, namely Aspose cannot be loaded via Maven.

I have already tried the following solution without success:

Here is the error message:
[ERROR] Failed to execute goal on project cpi: Could not resolve dependencies for project com.hauck-aufhaeuser:cpi:jar:2.23: The following artifacts could not be resolved: com.aspose:aspose-cells:jar:19.5, com.aspose:aspose-cells:jar:javadoc:19.5: Could not transfer artifact com.aspose:aspose-cells:jar:19.5 from/to AsposeJavaAPI (https://repository.aspose.com/repo/): transfer failed for https://repository.aspose.com/repo/com/aspose/aspose-cells/19.5/aspose-cells-19.5.jar: Received fatal alert: handshake_failure -> [Help 1]

Here is an excerpt from the pom.xml:

    <repositories>
        <repository>
            <id>AsposeJavaAPI</id>
            <name>Aspose Java API</name>
           <!-- <url>http://artifact.aspose.com/repo/</url> -->
            <url>https://repository.aspose.com/repo/</url>
        </repository>
    </repositories>

 <dependency>
            <groupId>com.aspose</groupId>
            <artifactId>aspose-cells</artifactId>
            <version>19.5</version>
        </dependency>
        <dependency>
            <groupId>com.aspose</groupId>
            <artifactId>aspose-cells</artifactId>
            <version>19.5</version>
            <classifier>javadoc</classifier>
        </dependency>

Is the whole thing possibly due to the current problems at Aspose with the API reference?
See: https://status.aspose.com/

The errors have been occurring since last week Thursday (19th of May 22)

@nikokottre,

I tested using your pom file contents and it works fine in a sample maven project using eclipse.
I found it works and the Aspose.Cells for Java v19.5 is installed/imported fine into the maven project. See the screenshot that shows it works ok on our end for your reference.
sc_shot1.png (54.9 KB)

We are not sure why it is not working on your end. Our concerned team who manages maven repository will evaluate it soon.

1 Like

Hi @Amjad_Sahi,

There seems to be something wrong about Azure and the SSL handshake. The question is, is it Aspose or Azure?

Log:

[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 02:58 min
[INFO] Finished at: 2022-05-25T10:29:41Z
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal on project cpi: Could not resolve dependencies for project com.mycustomer:cpi:jar:2.23: The following artifacts could not be resolved: com.aspose:aspose-cells:jar:19.5, com.aspose:aspose-cells:jar:javadoc:19.5: Could not transfer artifact com.aspose:aspose-cells:jar:19.5 from/to AsposeJavaAPI (https://repository.aspose.com/repo/): transfer failed for https://repository.aspose.com/repo/com/aspose/aspose-cells/19.5/aspose-cells-19.5.jar: Received fatal alert: handshake_failure -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException
The process '/usr/bin/mvn' failed with exit code 1
Could not retrieve code analysis results - Maven run failed.
No test result files matching /home/vsts/work/1/s/**/surefire-reports/TEST-*.xml were found, so publ

It seems like every second build runs through:
screenshot-1.png (38.0 KB)

@nikokottre

There seems to be something wrong about Azure and the SSL handshake. The question is, is it Aspose or Azure?

Are you using dedicated Azure VM? If yes, then can you please share its IP address so we can verify it at our end. Thanks.