Free Support Forum - aspose.com

ASPOSE Dlls with a strong name


#1

Hello,

at the moment, we are testing with ASPOSE dlls. I’ve tried adding them to the GAC using the gacutil tool. It tells me I that it fails, the assebmly is with no strong name

How would I get the signed dlls?


#2

@mhabibal,

After an initial test on Windows 10, we were unable to reproduce this issue on our end. For testing this scenario, we used the Aspose.Words for .NET 19.1 (DLLs only) package on our end and the following command.

gacutil -i E:\Temp\Aspose.Words.dll

As shown in screenshot the assembly gets added successfully:

So, there is no issue with Aspose.Words.dll. Which Aspose DLL are you getting this problem with?


#3

The Cells one

image.png (14.4 KB)


#4

@mhabibal,

Thanks for the screenshot.

Which version of the product (Aspose.Cells) you are using, please try our latest version v18.12 if you are not already using it. I have tested to register Aspose.Cells.Dll from net2.0 and net4.0 folders, it works fine, see the screenshot for your reference:


#5

I have 12.8.1.22. Still it doesn’t work


#6

@mhabibal,

I am afraid, we still do not know which Aspose.Cells version you are using, your mentioned does not exist. We recommend you to kindly try our latest version/fix: Aspose.Cells for .NET v18.12.x and let us know your feedback.


#7

Yes, I will try it. Thank you.
I have been using this one. I have just recognized it is not the same one!!
aspose pdf.PNG (43.2 KB)


#8

@mhabibal,

Thanks for the screenshot.

This version (v12.8.1.22) does not look like a valid version posted by Aspose. Please only use versions which are posted by Aspose on Nuget repos.
https://www.nuget.org/packages?q=Aspose