We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose.Email.SMTP.log not created

Hi Support,

We are using Aspose.Email.Mail.SmtpClient for sending email. We are sending email in bulk. After executing few emails, our software is giving outofmemory exception.
Tried to add Aspose.Email.SMTP.log, but log file not even created.
Below is the configuration we did in our configuration file.

<?xml version="1.0" encoding="utf-8"?> Aspose.Email.SMTP.log

Please let me know why no log created.

Exception details:
Exception of type ‘System.OutOfMemoryException’ was thrown.
InnerException: Exception of type ‘System.OutOfMemoryException’ was thrown.
InnerException: Exception of type ‘System.OutOfMemoryException’ was thrown.
Stack trace:
at #=qLyiSYq2x8fOfuYzh0DlW8IlITvuppOzbsOjV4eJBww_Y4qFwQiQ6O_9dNgNZqIdH.#=qWyj_c0xrO5dhhlMXe6zdTA==()
at #=qoFEQfx4qYq6BXfkqmiQ__T$p6DELk98DNL5B7$ZC4CqN7n5AWeBuegc3eEUs8gd5.#=qwv1lDnyT_YKRgJVo1yYDmFaflK4HlbuaY9fQv6n7mPQ=(Boolean #=qptF2TZeXKo3ShGthhRFBJg==, Stream #=qUFDnODQvKPyFjC4WzM0ZZA==, Int32 #=q1oavdavys9vtR6I8SrtFQg==)
at #=qoFEQfx4qYq6BXfkqmiQ__T$p6DELk98DNL5B7$ZC4CqN7n5AWeBuegc3eEUs8gd5.#=qDXbyfp_yEq_AUnzvDqPjjMowmBnQM8X8rl9Iy9lxr0E=(String #=qaKYZ9TTH6QJVtrc8UYG8Xg==, Int32 #=q$GKVoyRnNrXA0WNCqeqFEA==, SecurityOptions #=qjUs0tLhxRq$of70V_XSRbW6w3DKiRwrcWsQACAnoLJc=, Int32 #=q1oavdavys9vtR6I8SrtFQg==)
at #=qoFEQfx4qYq6BXfkqmiQ__T$p6DELk98DNL5B7$ZC4CqN7n5AWeBuegc3eEUs8gd5.#=qgYI0AnNMl6L8oWK3fNbH6h$f6yrFg1NLOcKoCEBJCcw=(String #=qaKYZ9TTH6QJVtrc8UYG8Xg==, Int32 #=q$GKVoyRnNrXA0WNCqeqFEA==)
These are the events leading to this exception:

@munishsdna,

Could you please share with us if you are using the latest version of API at your end? i.e. Aspose.Email for .NET 18.5.1. We have tested this at our end by sending few emails and were not able to reproduce the issue at our end. Please share more details about your environment with us like installed RAM, OS details 32 or 64 bit, and .NET framework you are using at your end. Does this occur when API is used in unauthenticated mode? If possible, please share sample emails from your emails dataset with us for further investigation at our end.

Hi Kashif,

We are using Aspose.Email version 17.2.
I remembered I faced Outofmemory problem in previous version of Aspose.Email and Aspose team fixed that problem in 17.2 version. After long time, still getting same problem.
Tried to add logging configuration to generate Smtp activity log. No log file is generated.
Above stack trace is not readable. Might be someone from your technical team can understand this.
Will share more information about environment once I will get from customer.

@munishsdna,

Please try it with Aspose.Email for .NET 18.5 now and let us know your feedback. If the issue still persists, provision of a test account on specifier server can be of help to us for reproducing the issue and investigating it further.

Hi Kashif,

Thanks for your reply.

I can’t ask customer to upgrade Aspose.Email with latest version.

Can you please let me know why Aspose smtp activity log not generated?

@munishsdna,

We need to have this information if the issue arises with latest version or not. In any case, we won’t be providing a fix if the issue exists with older version and doesn’t occur with latest version of the API. Please make sure that your client is using MailMessage.Dispose for messages he is sending out. About activity log not generating, we won’t be able to identify the issue unless it is reproduced at our end.

Can you please confirm me that smtp activity log only generated when there is any error while sending email or log generate everytime either mail send without error or with error?

@munishsdna,

This log is written in all the cases whether operation is successful or un-successful. Please feel free to write us back if you have any other query in this regard.