We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose excel chart error

Our original doc is Dokuman.xlsx. But after aspose functions our output doc “7ee49e9d-24b4-412a-902d-d853042924df [ 00H-018_1_7.xlsx ] [ 7 ] (1).xlsx” doesnt have chart.


what can we do to solve the problem?

Our aspose version is 7.7.2.0

Hi Ahmet,


Thanks for your inquiry. As your query is related to Aspose.Cells API, I am moving your thread in Aspose.Cells forum where you will be guided appropriately.

Best regards,

Hi,


Thanks for providing us template files.

I have tested your scenario/ case a bit using our latest version v8.0.2 (please try Aspose.Cells for .NET 8.0.2 ) with the following sample code, it works fine. All the charts are preserved in the output file as I confirmed (I simply opened your template file and re-saved it):
e.g
Sample code:

Workbook workbook = new Workbook(“e:\test2\Dokuman.xlsx”);

workbook.Save(“e:\test2\outDokuman1.xlsx”);

If you still find the issue with v8.0.2, please paste your sample code (runnable) and attach some screen shots to highlight the problematic areas, we will check it soon.

Thank you.

Hi ,


We take a xml error,while saving xml.

I tested last Aspose version and attached our problem screenshot.

Hi Ahmet,


We have re-evaluated your presented scenario while using the latest version of Aspose.Cells for .NET 8.1.1. Unfortunately, we are unable to see any problem while loading your provided spreadsheet and saving it back with SaveFormat XLSX. In case you are performing some additional operations on the said spreadsheet before saving it to disc, we would request you to please share your source code (most preferably a standalone sample application) to reproduce the problem on our side.

Thank you for your understanding & cooperation.

Hi,


I attached our test project and our test doc.

Thanks,

Hi Ahmet,


Thank you for sharing the sample project.

We have evaluated your presented scenario while using your sample application (without any changes) and recently shared spreadsheet. Unfortunately, we are unable to see any problem with the resultant spreadsheet and PDF files. We have attached the aforesaid files with this post for your kind reference. Please note, we used MS Excel 2007 & Excel 2010 (32-bit) to view the resultant spreadsheet. None of the Excel applications popped up message regarding the corruption of the spreadsheet, and the charts have seemed to be retained just fine. Additionally, we performed a few tests with Aspose.Cells for .NET 8.1.1 in a separate application using the code from your project. The results produced with latest version are also correct.

In order to dig deep into this scenario, please share the MS Excel version & architecture, so we may try to acquire the exact version to replicate the problem on our side. Please also share more details about your environment such as,

  • Operating System version & architecture (32bit/64bit)
  • Service Pack version
  • Target Framework version

Thanks for your attention.

We tested using Aspose.Cells 8.1.1.0 and no error has occured.
But we realized another error.

input.xlsx is original file and output.xlsx is converted via using aspose.cells.
Second sheet of input.xlsx you can see a chart. if you click one of blue bars you can see the formula above in formula text.(screen01.png)

After convertion -output.xlsx- if you check second sheet you can see the formula changes. aspose converts commas(,) to slash() in formula so chart value changes.

Could you please help us about this error?


Hi Ahmet,


Thank you for the confirmation on previously reported problem.

In reference to the recently shared scenario, we have noticed that the chart’s series formula has alter if your provided spreadsheet is loaded and saved back with Aspose.Cells for .NET 8.1.1. However, the changes on our end are little different, and they are not effecting the chart visually. Please note, we have used MS Excel 2007 & Excel 2010 (32-bit) to evaluate the problem on our side. With both cases, the results are similar, that is; the double quotes in the series data collection have been omitted. Please check the attached snapshot for your reference.

The aforesaid behavior is certainly not desired, therefore we will log an investigative ticket to look further into this matter. However, we are curious why are you getting different results. This could be due to the Excel version on your side, therefore please share the version/build of Excel application, so we could try to get the same version to replicate the behavior as you are experiencing it. Moreover, when we checked your provided output spreadsheet in Excel 2010, we found that double quotes in the series data collection have been replaced with slash. We suspect that you have saved the file with your version of Excel application after loading the Aspose.Cells generated results in it. Please provide also provide us your Aspose.Cells generated spreadsheet without loading it in Excel application. Reason being, in many cases Excel application tries to correct problem if found in a loaded spreadsheet, therefore we may not be able to see the original problem.

Hi Ahmet,


Just to bring in your knowledge that we have logged an investigative ticket (CELLSNET-42806) in reference to the behavior as discussed in my previous post. As soon as you provide more details, we will either enhance the existing ticket or log a separate one to tackle that particular scenario.

Hi,


We test this project in 2010 64bit excel and 2013 64bit excel. In two version same error occured.

Thanks

Hi Ahmet,


Thank you for providing more information.

We are moving forward to acquire the said versions of Excel application to confirm the problem on our side. For now, we have updated the existing ticket (CELLSNET-42806) and recorded the incident. We will keep you posted with updates in this regard.

Hi,


Does this problem solved?

Thanks.

Hi Ahmet,


Thank you for posting and using Aspose.Cells.

We are afraid, there is no update for you at this moment. However, we have logged your comment in our database against this issue. Please spare us some time. Once, there is some fix or other update for you, we will let you know asap.

Hi,

Please try our latest version/fix: Aspose.Cells for .NET v8.1.2.2


We have fixed the issue now.

Let us know your feedback.

Thanks,

The issues you have found earlier (filed as CELLSNET-42806) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.