We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose for Sitefinity component issues

Hi Support,

I have been trialing the Aspose for Sitefinity component and have come across a a couple of issues. I would like to know if they are purely based on the trial or it is something that needs looking into, before I can go ahead and purchase it

  1. The first issue is that when I click to export as PDF nothing actually happens, Word exports as expected
  2. The second issue is that if I put the component on a child page the component errors completely on click

Hi,

We are sorry for inconvenience. We have checked both the scenarios but unfortunately could not produce them at our end. Can you please send us error details with screenshot so that we can use this information to reproduce this issue at our end.

Please check the Youtube video for a visual demonstration of the Add-in.
https://www.youtube.com/watch?v=mopEZvGn_30

here is the link to the detailed error report I posted on your Codeplex

https://asposesitefinity.codeplex.com/workitem/1

Hi,

Thank you for providing the details. We are working on the issue and will get back to you very soon. Can you please tell us which version of Sitefinity you are using?

Thank you

It’s Sitefinity 7.0

Hi,

Thank you for your patience. We have investigated the issue in details using the latest version of Sitefinity i.e. 7.0.5100.0.

  1. The blank page is most likely due to PDF integration with the browser. We tested export to PDF with latest version of IE, Chrome and FireFox and found it working in all. Can you please try a different browser and also please tell us which browser and version you are using.
  2. We were unable to produce the error you mentioned even when tested upto 3 levels of sub-pages, with and without port based URLs and with a sub-domain URL but the error details suggest that the error is occurring when the code tries to fetch HTML of the current page using dynamically generated URL. Can you please tell us the exact URL which is giving you the error? We will then setup the exact same URL to test this scenario.

We look forward to hear your feedback and hope to resolve the issues you are facing very soon.

Thank you