Free Support Forum - aspose.com

Aspose.Grid only works in browsers in boxes with the Aspose kit installed

Hi all,

I'm using Aspose.Grid to develop a web page that will generate and manage some reports in Excel.

On my startup tests I came acrosse the following issue :

I installed an example in an IIS for a develpment server, and, when accessing a page, I noticed that, if Aspose was not installed in the box where I accessed from, the control would not work properly (check attach).

If I installed Aspose on that machine, it would start to work properly. It is not desirable to have Aspose installed on the client. It's suposed only a browser to be used and have Aspose installed only on the Server side.

Can anyone give me a hint? Is this suposed to happen?

Thank you,

Hi,

Thanks for considering Aspose.

Aspose.Grid.Web is a pure server side .Net control and is only installed on the server and does not require Aspose.Grid.Web to be installed on the client side. Could you give us some details about your OS, environment, .NET platform, IIS settings, HTTP or File System website mode. And are you using MS Ajax extensions. If you use File System or MS Ajax extensions, you may try to add some lines in the appSetting sections to the web.config file:


<add key="aspose.grid.web.agw_client_path" value="/agw_client/" />


Actually this config prevent the control from using embeded client resource(images, scripts, etc.). And this config will only take effect with LICENSED version of the control.

Thank you.

Hi,

I tried your configuration, but with the relative path :

<add key="aspose.grid.web.agw_client_path" value="/agw_client/" />

The control doesn't work properly. I can get it to work if I pass an absolute url :

<add key="aspose.grid.web.agw_client_path" value="http://localhost/agw_client/" />

but this is not desirable.

Is there a way to get around this?

Thank you,


Hi,

What kind of browser are you using? Is the demo project deployed on the default web site of the IIS or another virtual host whose TCP Post is other than the default value 80? We need to know further information about your environment. And could you please upload a sample project here?

Thank you.

Hi Henry,

Never mind the question… I had the wrong path in the key in web.config. Corrected that and it works fine, now.

Thanks for your reply
Cruz