Free Support Forum - aspose.com

Aspose.HTML v19.2.0 requires Microsoft.Windows.Compatibility (>= 2.0.0) as dependencie


#1

Hello,

we recognized that Aspose.HTML v19.2.0 officially requires Microsoft.Windows.Compatibility (>= 2.0.0) as dependency. It is possible to remove this dependency for .NET-Framework, isn’t it? It seems to me that it is not necessary anymore. Your response is awaited.

Best regards


#2

@daan0

Thank you for contacting support.

An investigation ticket with ID HTMLNET-1764 has been logged in our issue management system for further investigations. The ticket ID has been linked with this thread so that you will receive notification as soon as the ticket is resolved.


#3

@daan0

Thank you for being patient.

We have investigated dependencies used by Aspose.HTML for .NET API. Currently .NET Standard 2.0 requires Microsoft.Windows.Compatibility so it cannot be removed, but it can be simplified. Dependencies in latest version of the API look like this:

  • .NETFramework 2.0
    No dependencies.

  • .NETFramework 3.5
    No dependencies.

  • .NETFramework 4.0
    No dependencies.

  • .NETStandard 2.0

  1. System.Drawing.Common (>= 4.5.0)
  2. System.Security.Permissions (>= 4.5.0)
  3. System.Text.Encoding.CodePages (>= 4.5.0)

Please feel free to contact us if you need any further assistance.