We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose java classes to oracle

Hi there,

We tried to install Aspose.Words for Java to the Oracle 10g database for evaluation, but it showed some errors and all classes are invalid:

SQL> sho err Errors for JAVA CLASS com/aspose/words/zz:

LINE/COL ERROR -------- ----------------------------------------------------------------- 0/0 ORA-29534: referenced object APPS.asposewobfuscated/akd could not be resolved

the same for the other classes

So my question is it possible to install and use your components in Oracle 10g? is there any instructions?

Thank you in forward,

Denis

Hi

Thanks for your request. Oracle 10g by default works on Java 1.4. So you should use Aspose.Words JAR for Java 1.4. Make sure you are using a correct JAR.

Also, you can update Oracle to Java 1.5 or 1.6, then you will be able to use Aspose.Words Jar for Java 1.5 or 1.6.

Please let me know if you need more information, we are always glad to help you.

Best regards,

We've got Java Runtime Environment, Standard Edition (build 1.4.2_04-b05)

and Aspose.Words.jdk14.jar as follows:

-> loadjava -v -force -r -user oracleuser/oraclepassword Aspose.Words.jdk14.jar

.....

loading : class asposewobfuscated/aii$a
creating : class asposewobfuscated/aii$b
loading : class asposewobfuscated/aii$b
creating : class asposewobfuscated/aii
loading : class asposewobfuscated/aii
skipping : resource META-INF/MANIFEST.MF
skipping : resource META-INF/LE-E14C6.SF
skipping : resource META-INF/LE-E14C6.RSA
skipping : resource META-INF/services/java.nio.charset.spi.CharsetProvider
resolving: class asposewobfuscated/a
errors : class asposewobfuscated/a
ORA-29534: referenced object APPS.asposewobfuscated/akd could not be resolved
resolving: class asposewobfuscated/aa
errors : class asposewobfuscated/aa
ORA-29534: referenced object APPS.asposewobfuscated/akd could not be resolved
resolving: class asposewobfuscated/aaa
........ etc

Any thoughts?

Cheers,

Denis

ok some progress all classes are valid since I loaded them from \Aspose.Words.Java\lib folder

but simple class in Oracle is still invalid:

import com.aspose.words.*;

public class xxDocx {
public static void DocxToPdf(String dir, String filename)
{
Document doc = new Document(dir + filename + ".docx");
doc.save(dir + filename + ".pdf");
}
}

and throwing following when running:

ORA-06512: at line 4
29541. 00000 - "class %s.%s could not be resolved"
*Cause: An attempt was made to execute a method in a Java class
that had not been previously and cannot now be compiled
or resolved successfully.
*Action: Adjust the call or make the class resolvable.

Hi Denis,

Afraid, I can't understand what is ORA-06512 error and where is "%s.%s" class:). ORA-06512 error itself does not indicate the actual error, just a line number in your PL/SQL code.

Please, surround your java code with try/catch block to catch an exception and print out real stack trace.

Best regards,

Hi

Thank you for additional information. Could you please try running this method without parameters (just for testing purposes)?

import com.aspose.words.*;

public class xxDocx {

public static void DocxToPdf()

{

Document doc = new Document("C:\\Temp\\in.docx");

doc.save("C:\\Temp\\out.pdf");

}

}

As I can see the 4th line in your code (where the exception occurs is a signature of your method). So maybe the problem occurs because you are passing incorrect arguments into your method.

Best regards,

Problem solved in a very weird way, thank you Konstantin from cold Syberia )

Just for the knowledge base:

I've put the content to

try{

........

} catch (Exception ex) {
ex.printStackTrace();
}

or just adding "throws Exception"

and it worked! 0_0

That's how I've loaded java classes:

loadjava -user oraclename/oraclepassword -verbose -resolver "((* MYSCHEMA) (* public) (* -))" -force -resolve Aspose.Words.jdk14.jar

all good,

appreciate your help

Hi Denis,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for the info. All these multi-tier applications so tricky:)

By the way, “Cold and snowy Siberia” – it’s only about winter. As compensation we have very hot summer. So at the moment I write from hot Siberia:)

Regards,