We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose libaries and Maven assembly plugin

I tried to assembly a jar including aspose pdf as dependency.
It seems to hang the assembly pluging, after 1 hour I didn’t get the result.
I suppose the problem is the code obfuscation, but I’m not sure.
Anyway removing the dependency everithing works as before.
Could You suggest a soluton ?
Tks

@AxiomaBo

Can you please share a bit more details like how you are trying to achieve your requirements? Like how you are assembling a JAR? using which tool? Please share the steps to reproduce the same issue at our end so that we can further proceed to assist you accordingly.

I use maven assembly plugin, as usual, in order to create a single jar file containing all classes of a list of dependencies.
Usually that operation takes 3/4 minutes.
When I add one of aspose libraries (I tried using aspose-pdf and aspose-word-for-jasperreports, but only one at time) it become a never ending operation (I left it running for more than one hour and I was forced to stop it).
I upload the pom and the assembly file.
Tks
Error.7z (1.6 KB)

@AxiomaBo

We have logged an investigation ticket as PDFJAVA-41357 in our issue tracking system to further analyze this case. We will look into its details and keep you posted with the status of the ticket resolution. Please be patient and spare us some time.

We are sorry for the inconvenience.