We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose .Net Compatibility

After upgrading to .Net 4.7 Aspose.Words is throwing an exception:
System.Runtime.InteropServices.SEHException: ‘External component has thrown an exception.’

Is Aspose.Words version 14.5.0.0 compatible with .Net 4.7?

@RelaySoftware

Thanks for your inquiry. Please note Aspose.Words for .NET 14.5 contains .NET Framework 2.0 DLL that should work with .NET Framework 4.7. However, we will appreciate it if you please share a simple console application as ZIP file here to replicate the issue at our end. We will look into it and will guide you accordingly.

Furthermore, it is recommend to use latest version of Aspose.Words for .NET. As we maintain a single code base of our API and all the fixes and new features/enhancements are implemented in latest version of DLL.