Free Support Forum - aspose.com

Aspose.OCR samples on GitHub not working

When we download the zip and run the OCR project getting error of following assembly, tried to upgrade the below package from 1.4 to 1.5 but couldn’t resolve it.

Microsoft.ML.OnnxRuntime only supports the AnyCPU, x64, and x86 platforms at this time

Awaiting reply

@vinayakbaddi6

Sorry for the delayed response.

Would you kindly make sure that you are trying to run the examples with x64 mode of debugging. Also, try to remove and re-install the API using NuGet Package Manager. In case issue still persists, please let us know.

I have tried that, and I end up getting this message
System.IO.FileNotFoundException: ‘Could not load file or assembly ‘System.Runtime, Version=4.1.2.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a’ or one of its dependencies. The system cannot find the file specified.’

@vinayakbaddi6

Would you please share the OS Name and Version along with Visual Studio Version details which you are using at your side. We will further check the details at our end and share our feedback with you.

Windows 7 SP 1
Visual studio 2019 > 16.4.2

@vinayakbaddi6

The error seems related to configuration in Visual Studio. We are further checking it and will get back to you soon. Such errors occur if you do not choose x64 platform in VS (not AnyCPU, only x64).