We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose.Pdf image conversion performance

Hi,

I have tried out Aspose.Pdf .Net version 9.8.0.0 today because it contains this enhancement:
PDFNEWNET-32106 Improve the performance while converting PDF file to Image
I am sorry to say that for some PDF’s the image conversion is still very slow and I do not see significant performance improvement.
The particular situation I am facing is that a customer uses scans processed by Kofax, where each PDF page contains a full page image with OCR text behind the image. Now I understand that Aspose still needs time to render the text although it is behind the image, but in our tests Aspose.PDF image rendering is 25 times slower compared to direct extraction of the image (using iTextSharp). That difference is way too large.
The attached zip contains an example program demonstrating the difference, a sample customer scan is included. Results for converting first 4 pages to 300 dpi jpeg (same as native resolution of the scan) are:
Aspose.PDF 8.7.0.0: 33.09 sec
Aspose.PDF 9.8.0.0: 32.03 sec (3.3% faster)
iTextSharp image extract: 1.25 sec (2647% faster)
When I saw that PDFNEWNET-32106 was released in v9.8.0.0 I was hoping for a more substantial improvement in performance.
Best regards,
Berend Engelbrecht

Hi Berend,


Thanks for your feedback. We have managed to notice the performance issue while using your shared project and document. So logged an investigation ticket PDFNEWNET-37839 in our issue for further investigation and resolution. We will keep you updated about the issue resolution progress via this forum thread.

We are sorry for the inconvenience caused.

Best Regards,

Hello,

Any news about this? People continue complaining to me that the performance is insufficient and I cannot do anything about it myself.
Thanks and best regards,
Berend

Hi Berend,


Thanks for your patience.

The issue reported earlier is pending for review and I am afraid its not yet resolved. However I have requested the development team to further look into this matter and share the possible ETA regarding its resolution. As soon as we have some updates, we will let you know.

Just a reminder that there is no progress on this issue (most recent version still has same performance, seems even slitghly slower).

Hi Berend,


Thanks for your inquiry. I am afraid the investigation of the reported issue is still not completed. Currently product team is busy in investigating/fixing other issue in the queue. However we have raised the issue priority and requested the team to complete the investigation at their earliest and share an ETA/findings asap. We will notify you as soon as we made some significant progress towards issue resolution.

Thanks for your patience and cooperation.

Best Regards,

Hi,
+1! I’ have got same issue with last release.

I have to convert many PDFs from Scanner (Jpeg or jbig2)!

Png or Jpeg convertions :
Leadtools : 1.5s
Aspose : 7.8s

In attachement is my case : PDF with embedded JPEGs .

Thx in advance to improve performance.



Hi Thomas,


Thanks for your inquriy. We will appreciate it if you please share your Leadtools sample code using for the conversion, It will help us to investigate and address your issue.

We are sorry for the inconvenience.

Best Regards,

Hi Tilal,

Please find attached a code snippet: there are two methods, the first one uses Aspose for conversion, the second one LeadTools.

Best Regards,


Hi Thomas,


Thanks for sharing the source code. But I am afraid I am unable to test LeadTools code, I am getting BadImageformat exception. I will appreciate it if you please share a sample console project of LeadTools sample, so we will try to test the performance issue. We are sorry for the inconvenience.

Best Regards,

Hi,

My project work with a private nuget to add Leadtools dependencies.

Leadtools are C++ dependencies so - you can check out these remarks:

- Check your x64 or x86 platform (to resolve BadImageFormat).
- Copy all the Leadtools dlls dependencies / example with the default installation and x64 platform:
Copy “C:\LEADTOOLS 19\Redist\DotNet4\x64*” "PATH_BUILD"
Copy “C:\LEADTOOLS 19\ Redist\DotNet4\x64\Filters*” “PATH_BUILD”

- get your temporary license and call RasterSupport.SetLicense () in your code.

And everything will be ok.

Best regards,

Hi Thomas,


Thanks for the suggestions, I am looking into these and will update you soon.

Best Regards,

any updates on this issue?

@mike.doerfler

We are afraid this issue is still pending for investigations. However, would you please create a separate thread while mentioning all necessary details of the scenario if you are facing the same issue, so that we may investigate further to help you out.